Xft-Mozilla destroys font preferences of non-Xft Mozilla

RESOLVED WONTFIX

Status

--
critical
RESOLVED WONTFIX
14 years ago
7 years ago

People

(Reporter: felix.schulte, Assigned: blizzard)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040817

Mozilla with Xft enabled destroys the font preferences of non-Xft Mozilla
versions, making them *unuseable*.

Reproducible: Always
Steps to Reproduce:
1. Start (Xft-)Mozilla on Fedora Linux
2. Edit font prefs
3. Quit it
4. Open Mozilla on AIX (same home dir, shared via NFS)

Actual Results:  
Fonts broken, most spaces have zero width.

Expected Results:  
Normal fonts.

This appears to be a very annoying interoperability problem between various Unix
platforms and Linux.

A known workaround is to reset the font preferences each time the user starts
Mozilla, quitting Mozilla and start it again. Then the problems are gone.
Until... yes... until the user switches the workstation again.

Comment 1

14 years ago
Mozilla compiled with Xft enabled uses a different naming scheme internally
(including the pref names) for font names than the normal X11 Mozilla build.
AFAIK jshin had a workaround for the Postscript module a while ago, maybe the
same kind of workaround can be applied to the gfx/src/gtk/ XLFD font handling
code...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Reassign to GFX:GTK as the bug hides there...
Assignee: prefs → blizzard
Component: Preferences → GFX: Gtk
QA Contact: ian

Comment 3

14 years ago
doesn't block development
Severity: blocker → critical

Comment 4

12 years ago
Does this bug still occur in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Product: Core → Core Graveyard
Since there is no longer any such thing as a "non-Xft" build (or an "Xft" build - the whole shebang has been superseded) this is now moot.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.