Closed Bug 26382 Opened 20 years ago Closed 20 years ago

entering text in form element results in 2 event sequences

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: rubydoo123, Assigned: Brade)

Details

1. bring a page with form elements into composer
2. enter text within the form element
3. both the input widget and the editor see the event

we should stop processing the form element and not allow the editor to see the 
event. Currently, typing in the form element within the composer is how the 
default text is inserted.
setting to m15
Target Milestone: M15
I saw this on Mac so changing platform/OS to all.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Hardware: PC → All

*** This bug has been marked as a duplicate of 25161 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified in 2/11 build
Status: RESOLVED → VERIFIED
reopening bug... this bug may sound like it has to do with form elements in the 
editor but it's actually a general event handling issue.  I put the steps above 
in so that QA could verify once the issue has been resolved.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
Target Milestone: M15 → M16
moving to m17
Target Milestone: M16 → M17
Ender-lite should fix this, no?
this is now fixed; the editor is now calling PreventDefault() which is the proper 
way to flag events as handled (rather than returning an error code).
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
verified in 9/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.