RSS manager gets stuck trying to parse an invalid feed

RESOLVED DUPLICATE of bug 259777

Status

RESOLVED DUPLICATE of bug 259777
14 years ago
10 years ago

People

(Reporter: matthew, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.3) Gecko/20041010 Firefox/0.10
Build Identifier: Mozilla Thunderbird version 0.8 (20040913)

The feed provided by <http://www.drobe.co.uk/rss.php> does not validate so
clearly I'm going to get on to the owners to fix it.  However the Thunderbird
RSS feed manager gets stuck trying to parse it when I try to add it.  Clearly it
should not do this, rather it should kick it out telling the user that it's an
invalid feed.

The sticking is not terminal, the manager can be exited raising a query telling
you that a feed is being processed.

Reproducible: Always
Steps to Reproduce:
1. "Manage subscriptions"
2. "Add"
3. Enter URL
4. Progress message goes to "Verifying the feed..." and the bar goes to 100%
where it sticks.
5. Click "OK" or close window
6. Answer "Yes" to "Are you sure you wish to cancel subscribing to the current feed"

Actual Results:  
I didn't get the feed subscribed and I had to kill the manager and re-open it to
subscribe to a different feed.

Expected Results:  
Produced an error stating that the feed is not valid RSS and allowed different
feeds to be added.

Comment 1

14 years ago
I can vouch for this bug too.

*** This bug has been marked as a duplicate of 259777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.