Cell widths wrong when colspan used

RESOLVED DUPLICATE of bug 187550

Status

()

RESOLVED DUPLICATE of bug 187550
14 years ago
14 years ago

People

(Reporter: spam_from_bugzilla, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040719 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040719 Firefox/0.9.1

I have a table with 2 rows and 3 columns.  In the first row the middle column is
colspanned with the left column and in the second row the middle column is
colspanned with the right column, like this:

+--------------------+
|                 |  |
|--+--------------+--|
|  |                 |
+--------------------+

I have declared the left and right columns to be 10% wide.  But Mozilla displays
it with a zero-width middle column:


+--------------------+
|          |         |
|----------+---------|
|          |         |
+--------------------+

Here is the code:

<table>
  <tr>
    <td colspan="2">90% jg ghe uighgu erhg eugh eriugher uiehg eghergu hegui
ehguegherug ehrguehg eur hgeru eru giehge</td>
    <td style="width: 10%">10%</td>
  </tr>
  <tr>
    <td style="width: 10%">10%</td>
    <td colspan="2">90% g jgerj gergjer oigehrgerhg ergh eguerh gerog hergo
hergou ehgeo ugheoig uehrg oerhgerghe ohger</td>
  </tr>
</table>


If I add "width: 90%" to the colspan="2" cells I get a layout closer to what I
consider correct, with the end columns about 25% and the middle column about 50%.

Internet explorer displays it as I expected, and Konqueror is close.

I will attach example code and some screenshots.

(I bet this is a dupe, but a search didn't find anything - sorry.)


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 161755 [details]
HTML demonstrating problem
(Reporter)

Comment 2

14 years ago
Created attachment 161756 [details]
Mozilla screenshot
(Reporter)

Comment 3

14 years ago
Created attachment 161757 [details]
Konqueror screenshot
(Reporter)

Comment 4

14 years ago
Created attachment 161758 [details]
Internet explorer screenshot

Comment 5

14 years ago
Created attachment 161759 [details]
testcase with another row added

the testcse shows that if for every column a td exists the width information is
honoured.

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 187550 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

14 years ago
Thanks Bernd, I was sure this would be a dupe but couldn't find one.  I was
always searching for something including "width".  Maybe that word could go in
the summary for 187550?

Cheers,  --Phil
You need to log in before you can comment on or make changes to this bug.