If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View Source gives No Bundle and JavaScript errors

RESOLVED WORKSFORME

Status

Core Graveyard
View Source
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Nicholas Shewmaker, Assigned: mrbkap)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040803

When I want to view source for a page, either through the menu or Ctrl+U
shortcut, I get three consecutive "No Bundle" errors above the newly opened
source frame. The first two have focus (I can hit enter), but the third does not
(must use mouse or Alt+Tab).

I just happened to have my JavaScript Console open and it gives the following
error when attempting to View Source.

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/viewsource.js :: viewSource :: line 176"  data: no]
Source File: chrome://navigator/content/viewsource.js
Line: 176

The source is displayed, despite these errors.

Reproducible: Always
Steps to Reproduce:
1. Open JS Console to clear, if necessary
2. Load a page
3. View | Page Source or Ctrl+U


Expected Results:  
There should be no errors.

I have not yet updated to 1.7.3 because I think this might be a break in the
program. If I had upgraded, it might have simply been the reinstall and not the
new version that fixed the problem.  I wanted you to have the info on your radar.
(Assignee)

Comment 1

13 years ago
I'm going to mark this WFM (works for me). I cannot reproduce this problem
either on 1.7 or a day-old CVS build. Is it possible that your installation got
corrupted somehow?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey

Updated

7 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.