Find focus does not switch to the frame where mouse is clicked

RESOLVED DUPLICATE of bug 197246

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 197246
14 years ago
10 years ago

People

(Reporter: Ravi Kanth Chintakunta, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

In IE, the find focus shifts to the frame where the mouse is clicked.

This feature is very useful (see the URL provided). First we find the class in
the left frame, click on the link, see the contents of that class in the right
frame. Then I click on the right frame and start finding in that frame (that is
withing the API of the selected class). But the find does not shift focus to the
right frame. Finding continues to find in the left frame itself.

Reproducible: Always
Steps to Reproduce:
1. Click on the above URL
2. Click on the left bottom frame
3. Find File in that frame.
4. Continue finding until you find a File - whole word.
5. Click on File link in that frame.
6. File's API is displayed in the right frame.
7. Click the right frame
8. Now try to find a word in the right frame contents. The search continues in
the left frame but does not do it in the right frame.

Actual Results:  
The search happens in a cyclic manner in all the frames that are displayed in
the page.

Expected Results:  
The search should start in the frame where the mouse is clicked and the search
should be limited to that frame.
*** Bug 269267 has been marked as a duplicate of this bug. ***
*** Bug 272265 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
By the way, Mozilla (which still has the classic find dialog) *does* switch to
the correct frame when you click on it and continue the find. As did Firefox
with the classic Find dialog before the new Find widget was introduced.

Comment 4

14 years ago
Dup of bug 197246 ?

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 197246 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.