If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Using auto scroll (middle or other mouse buttons) to navigate up and down pages uses 100% CPU

VERIFIED DUPLICATE of bug 247260

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 247260
13 years ago
13 years ago

People

(Reporter: Kris Silver, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041006 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041006 Firefox/0.10.1

Using autoscroll (the centre or other mouse button) to scroll in pages is
firstly, allot slower and jerkier than any other browser, especially compared to
using the sidebar.  This has been mentioned before.  More specifically, using
autoscroll sends the CPU usage upto 100% within seconds on every computer I've
used Firefox on.  It slows the whole computer right down, takes CPU away from
other programs and makes Firefox especially, jerky and un smooth/professional
feeling.  IE and any other browser does not do this, they use 10% CPU and
navigate as smoothly and efficienty as the sidebar.  This is a very serious
common browsing usage problem that I hear many people experiencing, and find
many more users who did not realise with the problem, until I made them do the 3
point test below, showing them how bad it is, and how IE/Opera responds far far
better, or rather...as it should do - normally.

Reproducible: Always
Steps to Reproduce:
1. CTRL>ALT>DELETE -> Performance  -  minimise to tray
2. Scroll around web pages using the middle or other mouse button
3. Watch the green level on the taskbar (CPU usage/performance) rise drastically.

Actual Results:  
Slow, jerky navigation, program slows down, lose where you are on the page,
other programs slow right down.

Expected Results:  
Smooth scrolling as with the sidebar, and any other browser.

THIS MUST BE FIXED.  RIDICULOUSLY COMMON USAGE PROBLEM.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 247260 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.