If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

hidden iframe hides bar cursor (caret) in form input element

RESOLVED DUPLICATE of bug 226933

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 226933
13 years ago
13 years ago

People

(Reporter: Tim Penhey, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

<html>
<body onload="document.exec.test.focus()">

<form name="exec" action="javascript:alert('missing cursor')">
  <input name="test"/>
</form>

<iframe style="visibility:hidden;position:absolute;top:0px;left:0px"></iframe>

</body>
</html>


Reproducible: Always
Steps to Reproduce:
1. Get firefox to load HTML from Details

Actual Results:  
Entry field that has focus but no cursor (caret) showing.

Expected Results:  
Text input should have flashing bar cursor (caret).

If hidden iframe covers input element, bar cursor is not visible.
If you remove the top and left style from the hidden iframe, the cursor is
visible, but I think this is due to the default positioning of an absolute
element without defined position.
If iframe "hidden" using display:none, cursor appears as expected.
I can see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

But I can't see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041011
Firefox/0.9.1+

I think this bug has been fixed already, somehow.

Comment 2

13 years ago
*** Bug 267206 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
I have this simlar problem, reproduced in a slightly different way.  Please see
my attachment to bug #267206.

*** This bug has been marked as a duplicate of 226933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.