identities use wrong SMTP server for sending mail

VERIFIED DUPLICATE of bug 235762

Status

defect
--
major
VERIFIED DUPLICATE of bug 235762
15 years ago
15 years ago

People

(Reporter: mozilla.jgvons, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041005 Firefox/0.10
Build Identifier: 

I'm using daily builds of thunderbird 0.8, currently the one from Oct 7th 2004,
but I think this problem exists since the multiple identities were introduced.

I have three accounts set up in TB, the second one with multiple identities:

work-account, SMTP server smtp_work
home-account, SMTP server smtp_isp (default SMTP server)
     identity_1
     identity_2
     identity_3
other-account, default SMTP server

What I notice is that when I send a message using one of the 3 alternate
identities, sometimes the SMTP server from the work account (smtp_work) is used
instead of the smtp server of the account they're associated with (smtp_isp).

When this problem occurs, the mail also ends up in the wrong sent folder, i.e.
in the sent folder of the work account instead of the sent folder of the home
account.

Note that the From: dropdown in the compose-mail window always lists the correct
correspondence between the identities and the accounts.

Although I tried, I'm not yet able to reliably reproduce it. It does happen a
2-3 times per week I think (on about 20-30 outgoing mails)

In my case, the work_smtp server does accept to send the mails, but if it would
have been another ISP account, it would probably have refused to relay the mail
(because of ISPs only relaying for people that dial in to their network).


Reproducible: Sometimes
Steps to Reproduce:

Comment 1

15 years ago
The fix referenced at the duplicate changes things so that the smtp server 
setting is inherited when creating a new identity; however, any identities 
created from before the fix will continue to have whichever SMTP server they 
were create with.  This setting can be fixed by editing prefs.js.

*** This bug has been marked as a duplicate of 235762 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.