Status

()

VERIFIED INVALID
14 years ago
12 years ago

People

(Reporter: acstreet, Assigned: bugs)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I downloaded Firefox and it installed a shortcut on my desktop.  So as to keep
the desktop uncluttered, I right clicked the icon and clicked on "Pin to start
menu," which it did.  I then sent the desktop icon to the recycle bin.  The
start menu shortcut does not work.  To make it work, I have to restore the
desktop icon then the shortcut on the start menu will work (so will the desktop
icon.

What's wrong?
Tony


Reproducible: Always
Steps to Reproduce:
1.install desktop icon
2.pin to start menu
3.send desktop icon to garbage
4.start menu icon will not work
5. restore desktop icon
6. start menu icon will work
Assignee: general → bugs
Status: UNCONFIRMED → NEW
Component: Browser-General → Installer
Ever confirmed: true
Product: Browser → Firefox
QA Contact: general → bugzilla

Comment 1

14 years ago
You have this problem because windows is thinking that you want to make a
shortcut from the desktop link, which in turn is a shortcut to the actual
program. By deleting the desktop icon, you're cutting it's link to the program.
You can either open the firefox folder & right click the main program to pin to
the start menu, or (what I would do), drag the shortcut that should be located
under programs to the main start menu list. Hope that helps...
^_^

Comment 2

14 years ago
First of all, I would like to say that this problem is not related to Firefox.

When you choose "Pin to Start Menu", Windows XP won't create a Shortcut to your
program (as many of us would expect), but stores somewhere in the registry that
the Desktop Shortcut you have just pinned should also be shown on the Start
Menu. Due to the fact that the registry stores the path of your Desktop
Shortcut, removing it will make the Start Menu Shortcut unusable.

I will give one of the solutions that christy suggested more detailed:
1) Go to "C:\Program Files\Mozilla Firefox" (or wherever you installed Firefox)
2) Right-click "firefox.exe" and choose "Pin to Start Menu".

I hope this works.
Cristi.

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.