File download progression wraps around to negative indicators - download performance drops

RESOLVED DUPLICATE of bug 228968

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 228968
14 years ago
2 years ago

People

(Reporter: WC -Sx- Jones, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817

When the file size passes 2GB the indicators start subtracting each downloaded
byte -- the main issue is that download performance drops substantially.

The download, albiet slower, appears to proceed =/

-Sx-

Reproducible: Always
Steps to Reproduce:
1. Goto indicated URL
2. Download the DVD ISO

Actual Results:  
When the file size passes 2GB the indicators start subtracting each downloaded
byte -- the main issue is that download performance drops substantially.

The download, albiet slower, appears to proceed =/


Expected Results:  
The download should continue at "positive" download ratio speeds.

Comment 1

14 years ago
Negative indicators: related to/duplicate of bug 242859 -> bug 184452?
(Reporter)

Comment 2

14 years ago
I would hazard it is related to "signed integers" - if that is truly what "bug
184452" is refering to.

Non-signed integers should have an addressable range between 0 and 4GB -- by
using signed integers the space for 32 bits would naturally be -2GB to +2GB

At anyrate, I tried to download the DVD iso twice and both times it ended in a
corrupt download because the networking checksum was out-of-sync with the
negative download ration calculation.

Thx/Sx
negative progress is bug 228968

slowdown is news to me, though... hence, not marking dup

> corrupt download

that should not happen. can you file a bug about that? (or find an existing
one). this is independent of the cosmetic issue of negative progress.
(Reporter)

Comment 4

14 years ago
I have downloaded the 4GB+ DVD from FC2 site several times now and when the data
downloaed hits 4,096,000,000 (4GB+) it dies with a network error; data corrupt?

Something like that - Ive been on this too long - Ill file a new bug about the
4GB+ network error tommorow.

-Sx-
The 4GB stuff is covered by bug 184452, as far as I can tell.  So this is a dup
of bug 228968
bz: I don't think we have a bug about this part of comment 0:
> The download, albiet slower, appears to proceed =/
Ah, true.  Nevermind, then.

Comment 8

14 years ago
I see the same behaviour on Linux.
Fedora Core 3, Firefox installed as an RPM, version 1.0.0-1.3.2

Download counters wrap to negative when I try to download the DVD ISO of Fedora
Core 3

I suspect my system was near to running out of disk space, which may be
a factor. But may not. I had a few hundred Meg left at one point
before I cleared more space.

Comment 9

14 years ago
I see the same bug, including the slowdown. 

Interestingly, the download is slowing down at a very steady rate, about 0.1
KB/sec per second (KB/sec^2). 

I am running Firefox 1.0.1, installed from RPM, on Fedora Core 3. 

The download in question is FC4-test1 from Norway mirror (I live in Denmark):
ftp://ftp.uninett.no/pub/linux/Fedora/core/test/3.90/i386/iso/FC4-test1-i386-DVD.iso

/Jacob Tjørnholm
This bug was fixed by bug 228968.  Should dup to bug 228968.

Comment 11

13 years ago

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
I want to point out that the reason I did not mark this as a duplicate is that
that bug does not cover the performance issues mentioned here (see comment 3)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.