Firefox uses wrong character coding on some websites

RESOLVED DUPLICATE of bug 258478

Status

RESOLVED DUPLICATE of bug 258478
14 years ago
3 years ago

People

(Reporter: marcus, Assigned: wolf)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
On the mentioned url Firefox uses Unicode (UTF-8) instead of iso-8859-1 which
would be correct

Reproduce: Be shure to use default character coding iso-8859-1 and visit
http://update.mozilla.org/?application=firefox. You will see some inverted ?
chars instead of the correct characters (dashed). Now open the View menu and the
character coding submenu. You see that Firefox uses Unicode (UTF-8) although the
html defines <meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1"> and the default setting of th browser is also iso-8859-1.

Expected: Firefox should always use the correct character coding

I see this bug with 1.0 preview on Windows and Linux builds.

Comment 1

14 years ago
http://update.mozilla.org/?application=firefox

GET /?application=firefox HTTP/1.1
Host: update.mozilla.org
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5)
Gecko/20041006 Firefox/0.9.1+
Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive

HTTP/1.x 200 OK
Date: Tue, 12 Oct 2004 06:26:55 GMT
Server: Apache/2.0.46 (Red Hat)
Accept-Ranges: bytes
X-Powered-By: PHP/4.3.2
Set-Cookie: PHPSESSID=afd5105412c4607d8a5da92cae2f36f3; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html; charset=UTF-8

The server is sending as UTF-8, which automatically takes precedence over
anything in the HTML meta tag.
Assignee: bugs → psychoticwolf
Component: Web Site → Update
Product: Firefox → mozilla.org
QA Contact: mozilla.update
Version: 1.0 Branch → other
(Assignee)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 258478 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

14 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.