Closed Bug 263976 Opened 17 years ago Closed 17 years ago

Reply-to extracts the wrong address

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: maf, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040928 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041011

The bug strikes when replying to an email with a From:-line like this:

From: =?iso-8859-1?Q?Martin=2C_Forss=E9n?= <maf@tkrat.org>

Mozilla thinks this line contains two addresses while it only contains one. The
bug is most likely caused by the comma which is encoded within the encoded word.
But as far as I can see the above use is legal since and encoded word can be
used "As a replacement for a 'word' entity within a 'phrase'" (rfc2047 section 5
.(3)).

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




When forwarding a message like this inline it shows the from address correctly.
The same applies if I try to bounce the message in Thunderbird 0.8.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.