Spellcheck suggests separation of compound words in none-english language

RESOLVED DUPLICATE of bug 216267

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 216267
13 years ago
9 years ago

People

(Reporter: Fredrik Toftered, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

Hello,

When I use my swedish dictionary in Mozilla's spellcheck and use compound words,
Mozilla's spellcheck suggests separation of the word, if the word is not in the
dictionary. An example. In english you say "address book" in two words. In my
country we say "adressbok" in one word.

If I write "adressbok" and use my swedish dictionary, and the word isn't in the
dictionary, Mozilla suggests me to change "adressbok" to "adress bok".

These suggestions is a feature when you write in english but an annoyance when
you write in other languages that don't separate compound words. I have to add
right-spelled word all the time.

I did a test with OpenOffice and copied sv_SE.aff and sv_SE.dic from my folder
"wordbook" in OpenOffice to the folder "myspell" in Mozilla. Then I wrote the
same words in OpenOffice and Mozilla and used this dictionary. Only Mozilla
suggested separations of compound words.

I would like to have this fixed so that Mozilla only suggests separations when
you write in english.

Fredrik

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 216267 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.