If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Extended characters in RSS 1.0 summary are displayed wrong

RESOLVED DUPLICATE of bug 272875

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 272875
13 years ago
9 years ago

People

(Reporter: Achton N. Netherclift, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: version 0.8 (20041011)

An RSS 1.0 feed with, for example, and ISO-8859-1 identifier (like the supplied
URL) will display extended characters in its description wrong. See the attached
image for an example.

Reproducible: Always
Steps to Reproduce:
1. Subscribe to an RSS 1.0 feed with extended chars in description
2. Display items with extended chars in TB
3. See that the extended characters in descriptions are wrongly displayed

Actual Results:  
The characters were displayed wrong, garbled. As in UTF-8, perhaps.

Expected Results:  
Displayed them as HTML entities or translated the characters according to the
supplied charset.
(Reporter)

Comment 1

13 years ago
Created attachment 161843 [details]
Example of wrongly displayed characters.
(Reporter)

Updated

13 years ago
Attachment #161843 - Attachment is obsolete: true
(Reporter)

Comment 2

13 years ago
Created attachment 161844 [details]
Example of wrongly displayed characters.

Comment 3

13 years ago
You get this same problem with many (all?) blogs from the blog-platform joueb.com 
(http://joueb.com/texts/active_sites.shtml)
For example : http://-abyskaya-.joueb.com/index.rdf

It seems the 8bit character is converted to Unicode, but the two bytes of the
Unicode are displayed as two 8bit characters.

The two cases have in common that they use the .rdf format and
encoding="iso-8859-1".

There is the same problem with the initial title of the blog, retreaved when you
add it.
could this be a dup of bug 270125?

*** This bug has been marked as a duplicate of 270125 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

13 years ago
this was incorrectly marked as a dupe.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 6

13 years ago
fortunately I just fixed this today against another bug...

*** This bug has been marked as a duplicate of 272875 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.