Rename key (the one right to the right command key) not working

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Sébastien Pierre, Assigned: Vladimir Vukicevic (BM, do not Cc or Request))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When selecting a bookmark from the bookmark manager and hitting the rename key
(a rotated '|<', right next to the right command key), Firefox opens the
bookmark link instead of editing either bookmark name or URL.

Reproducible: Always
Steps to Reproduce:
1. Bookmarks -> Manage Bookmarks...
2. Select (single click) a bookmark (not a folder) from the right pane
3. Hit the "rename" (|<) key

Actual Results:  
The bookmark opened in a Firefox window

Expected Results:  
The bookmark name or URL should become editable "in place"

Comment 1

13 years ago
Rename key ? That the first time I see it being called like that. On my original
iBook it's the return (or enter, I can never remember the difference). It also
generates the same keycode (13).

So you want to rename the bookmark when return/enter is pressed, not open it ?
(Reporter)

Comment 2

13 years ago
Well, I have a TiBook and this key has code 3 whereas the return key has code
13. This key can be used 
anywhere in MacOS apps to rename element, thought I am not sure that it is
called "rename key".

As I stated it, the symbol on it is a |< rotated 90 degrees right.

To answer your question, I do not want return to rename the bookmark (this would
be obviously 
unnatural), but that this precise key, usually used to rename elements, actually
allows to rename an 
element in Firefox.

For instancce, Safari bookmarks have the expected behaviour I describe (hitting
the |< key makes the 
bookmark editable).

Comment 3

13 years ago
(In reply to comment #2) 
> For instancce, Safari bookmarks have the expected behaviour I describe (hitting
> the |< key makes the 
> bookmark editable).

So does the return-key (tested in Finder and Safari). I think you're assuming
that this is a special key, but it just executes the default action, when
triggered by return or enter.

See bug 194923 (especially bug 194923 comment #7) which basically asks for the
same thing (in a platform-independent way).

Duplicate?

Comment 5

13 years ago
I don't think this is a duplicate of bug 194923 because it's for the contextual
menu. This bug is for renaming it by selecting it and pressing a key.

So what you're asking for is basically the same thing Safari's bookmark manager
has? Just select a bookmark, press return and rename it. Also you could click on
it and then click on it again and you can rename it. Same thing with the Finder.

Changing Severity to enhancement.
Severity: normal → enhancement
(Reporter)

Comment 6

13 years ago
You almost got it : I would like to be able to rename a bookmark in the bookmark
list by presssing a key which is NOT THE RETURN KEY, but a SPECIFIC KEY which
seems to have disappeared from newer Mac keyboards. This key has a rotated |<
symbol on it, and has KEYCODE 3.

This key can be used in almost any MacOS app (including Safari) to rename elements.
Assignee: vladimir → vladimir+bm

Comment 7

13 years ago
(In reply to comment #6)
> You almost got it : I would like to be able to rename a bookmark in the bookmark
> list by presssing a key which is NOT THE RETURN KEY, but a SPECIFIC KEY which
> seems to have disappeared from newer Mac keyboards. This key has a rotated |<
> symbol on it, and has KEYCODE 3.
> 
> This key can be used in almost any MacOS app (including Safari) to rename
elements.

Unless you get more specific and tell us what other keys it is near on the
keyboard or attach a picture, no one will understand this request. The |< key
sounds like a backspace/delete or tab.

Comment 8

13 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > You almost got it : I would like to be able to rename a bookmark in the bookmark
> > list by presssing a key which is NOT THE RETURN KEY, but a SPECIFIC KEY which
> > seems to have disappeared from newer Mac keyboards. This key has a rotated |<
> > symbol on it, and has KEYCODE 3.
> > 
> > This key can be used in almost any MacOS app (including Safari) to rename
> elements.
> 
> Unless you get more specific and tell us what other keys it is near on the
> keyboard or attach a picture, no one will understand this request. The |< key
> sounds like a backspace/delete or tab.

It's just a return or enter key, located right of the spacebar. On my iBook, it
works exactly as the return key. Applications just treat it as another return
key, although it was supposed to have a different behaviour (like ending a
paragraph). But I have never seen 1 application that uses it different form the
normal return key.

The reporter is assuming it's a special 'rename' key, while it's just execting
the default action, just like pressing the real return does. Safari starts
renaming an bookmark entry if you press return (or this 'rename' key). Firefox
doesn't, becuase the default action is to open the bookmark.

That's all. Not worth fixing, unless someone thinks that renaming a bookmark is
a better default action than opening one.

Comment 9

13 years ago
> That's all. Not worth fixing, unless someone thinks that renaming a bookmark is
> a better default action than opening one.

In that case a new bug should be filed. /me closing this one
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.