javascript file is loaded from xul as ISO-8859-1 but realy is UTF-8

VERIFIED DUPLICATE of bug 241739

Status

()

Core
XUL
--
major
VERIFIED DUPLICATE of bug 241739
13 years ago
9 years ago

People

(Reporter: Dainius Daujotas, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

236 bytes, application/x-javascript
Details
332 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3) Gecko/20040921
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3) Gecko/20040921

I can't create any element from external javascript with encoding other than
ISO-8859-1. I think browser loads script's and ignore character encoding.

Reproducible: Always
Steps to Reproduce:
1. Create javascript file with function (alert or create label ....) and user in
strings with other tan ISO-8859-1 charset
2. Create xul file with call to that function


Actual Results:  
Displays characters in iso-8859-1 encoding

Expected Results:  
Lithuanian characters in label and alert
(Reporter)

Comment 1

13 years ago
Created attachment 161854 [details]
Javascript for test
(Reporter)

Comment 2

13 years ago
Created attachment 161855 [details]
Second file for test
Created attachment 161875 [details]
Testcase that can just be run
Attachment #161855 - Attachment is obsolete: true
Not JS engine.
Assignee: general → nobody
Component: JavaScript Engine → XP Toolkit/Widgets: XUL
QA Contact: pschwartau
Summary: javascript file is loaded from xul as ISO-8859-1 but realy is UTF-8 → javascript file is loaded from xul as ISO-8859-1 but realy is UTF-8
And a dup.

*** This bug has been marked as a duplicate of 241739 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
indeed. vrfy.
Status: RESOLVED → VERIFIED
yep, the testcase here now works correctly with the patch from bug 241739
(although it was at first a bit hard to tell for me that the output is the
expected one :-) )

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.