text-decoration does not work properly for input element (type=submit,button) if the html doctype has been specified

RESOLVED DUPLICATE of bug 219516

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 219516
14 years ago
14 years ago

People

(Reporter: Marco Ochschim, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041011 Firefox/0.9.1+

If the document type information "<!DOCTYPE HTML ... >" (at the top of the 
HTML document) has been given, the style property "text-decoration", which was 
defined at/for an "input" element of type "submit" or "button" via the "style" 
attribute/CSS, is not processed by the browser properly.
The text contents of these elements are not displayed underlined, overlined 
and lined-through.

Reproducible: Always
Steps to Reproduce:
1. Create simple HTML code like this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 
4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<input style="text-decoration: underline; border: none;" type="button" 
value="This Text should be underlined!">

2. Open that html with firebird (5+) or netscape (7+)
3. Comment out the doctype statement <!--DOCTYPE ... //-->
4. Open that html again, but altered now, with firebird (5+) or netscape (7+)
Actual Results:  
for 2.) text isn't displayed underlined
for 4.) text is now displayed underlined

Expected Results:  
for 2.) incorrect behaviour: text must be displayed underlined
for 4.) correct behaviour

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 219516 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.