form reset not executed on page reload through reload button

VERIFIED DUPLICATE of bug 46845

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 46845
13 years ago
9 years ago

People

(Reporter: Dieter Demerre, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

When a page containing a form is reloaded through the reload-button of the
Navigation bar, the (some?) fields of the form are NOT reset to their original
value.

When reloading the page by clicking the Address-field and pressing [enter], the
form is correctly reset to its original state.

Reproducible: Always
Steps to Reproduce:
1. fill in something in the field
2. press the reload-button in the navigation toolbar
3. constatation: contents of field remains.

Actual Results:  
The fields of the form (hidden or not) retain their value.

Expected Results:  
The fields should have been reset to their original value.
(Reporter)

Comment 1

13 years ago
Problem also occurs with a Ctrl-R initiated reload.
Problem seems not to be related to "keep form field values", since it occurs
also when disabling this feature and clearing the stored fields.
This bugs me too:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20041005 Firefox/0.10.1
Is this by design?
Component: Toolbars → Form Manager
OS: Linux → All
QA Contact: bugzilla → firefox.form-manager
(Reporter)

Comment 3

13 years ago
Problem - if it's considered one - also occurs in Firefox 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.