</tr> inside malformed link prematurely ends the table

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: lz_ufo, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803

The page at http://www.nettuno.units.it/INGEGNERIA/dateingegneria.html
contains some tables with univerity's exams, dates, teachers, etc. but
Mozilla show them in wrong : order, alignament, position, etc. etc.
Try to watch the same URL using Internet Explorer for understanding
the difference. :(
Thank you :)

Reproducible: Always
Steps to Reproduce:
1.open with Mozilla http://www.nettuno.units.it/INGEGNERIA/dateingegneria.html
2.open the same url with Internet Explorer (ME/XP/2000)
3.

Actual Results:  
With step 2 I am able to read the tables but I am not with step 1 !!!

Expected Results:  
Show url like step.2

I use classic theme for Mozilla

Comment 1

14 years ago
Removing (ninety one) of 

<a </TR>

seems to fix this for Mozilla (agreeing with Opera's interpretation of the
unaltered document).

Comment 2

14 years ago
I'd say "Garbage in, garbage out." and propose marking this bug INVALID or
WONTFIX. Or is this a special case the HTML parser should work around?

Comment 3

14 years ago
878 validation/markup errors according to the W3C validator, 264 font tags, etc.

Resolving as INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 4

14 years ago
I think this belongs in layout: tables instead (at least for bernd to look at
before marking invalid again)
Status: RESOLVED → UNCONFIRMED
Component: Layout → Layout: Tables
Resolution: INVALID → ---

Comment 5

14 years ago
Created attachment 161933 [details]
minimal testcase

Comment 6

14 years ago
Okay, so this is actually Parser. Probably still invalid, or more likely yet, a
dupe, but I'm not qualified to make that call (especially since in quirks mode
we might want to follow IE on things like this).
Oh, tested only with 1.7.3, btw. Someone with a recent trunk build might want to
look at this, in case it is already a WFM.
Component: Layout: Tables → HTML: Parser
Summary: It's a total confusion !!! Try it with MS-Internet Explorer for WinME/XP/2000 → </tr> inside malformed link prematurely ends the table

Comment 7

14 years ago
this is identical to the situation with winxp 2004100906. Please note that IE
and opera both dont push the text outside the table.
Assignee: nobody → parser
QA Contact: core.layout
This bug is INVALID. The problem is that SGML says that you're allowed omit the
closing > of a start tag. Therefore, when we parse the <a </tr> as <a></tr>,
causing the <tr> to be closed when we see the text, and as text isn't a valid
child of a table (directly), we move it out of the table.

IE (and presumably Opera) violate SGML and parse the </tr as:
<a tr>, which leaves the <tr> in the table open, so the text stays inside.

There really isn't anything we can do about this quirk (and we shouldn't!).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.