Shorten titles in multiple tabs to make them more useful/significant

RESOLVED DUPLICATE of bug 128145

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 128145
14 years ago
13 years ago

People

(Reporter: yuhuibc, Assigned: bugs)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

(This is similar to bugs 128145 and 200196.)

Taking yet another page from Apple's Safari...
When there are multiple tabs in Safari which are pages from the same website,
Safari will shorten the tab titles to make them more signficant by removing
redundant portions,

e.g. Yahoo! News' titles are "Yahoo! News - blah blah blah", but if there are
multiple tabs showing Yahoo! News pages, then the tab titles will just show
"blah blah blah", i.e. leaving out the "Yahoo! News - " part.

This makes better use of the limited space in tabs to display a more significant
title for the user.

Reproducible: Always
Steps to Reproduce:
1. Go to Yahoo! News.
2. Open a lot of news stories in tabs.
3.

Actual Results:  
The tab titles retain the <title> of their containing web pages.

Expected Results:  
Shorten the titles by leaving out redundant portions, e.g. "Yahoo! News - ".
Assignee: tabbed-browser → bugs
Component: Tabbed Browser → Tabbed Browser
Product: Browser → Firefox
QA Contact: firefox.tabbed-browser

Comment 1

14 years ago
dupe of bug 128145 ?

Comment 2

14 years ago
I agree that this is a duplicate of bug 128145.

*** This bug has been marked as a duplicate of 128145 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.