Closed Bug 264151 Opened 17 years ago Closed 17 years ago

Special German characters like ä, ö cause problems with "reply"-Button

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: Holger, Assigned: mscott)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

If the sender of an e-mail is i.e. "hans glück" and you press "reply"
thunderbird 0.8 will try to replay to "hans" and to "Glück" as to two separate
accounts.

Reproducible: Always
Steps to Reproduce:
1.Create an account with the described characters
2.Send an e-mail
3.Reply to it

Actual Results:  
see above
It will try to find "hans" as an e-mail account which usually still contains the
corect address and "Glück" which contains no address at all. May be you will get
a bounce message.

Expected Results:  
should reply to "hans glück" as a unique address
Is the original address actually "Hans Glück" or is it "Glück, Hans"?
The latter is a known problem; see bug 254519.

If you are not convinced that bug is the same as this, please find (or create) a 
sample message that shows the problem, save it as a .EML file, and attach it to 
this bug using the Create New Attachment link above.
From the attachment:
-------------------
Example of a person:
From: =?iso-8859-1?B?Ikf8bfxzbPwsIENhbmFuIg==?= her name is Canan Gümüslü, 
message sent 28 April 2004, is diplayed correctly
From: =?iso-8859-1?B?R/xt/HNs/CwgQ2FuYW4=?= the same person, message sent 09 
Sept 2004, is displayed as mentioned above.
-------------------
That's the clue needed.
The first From: decodes as  "Gümüslü, Canan"   with quote marks
The second From: decodes as   Gümüslü, Canan    without quote marks

The first presumably was from a message created by Mozilla or TB; that's a known 
issue with its RFC 2047 encoding -- the quotes shouldn't be necessary.  But the 
duplicate is about how, *without* quotes, the name string is incorrectly treated 
as two separate addresses.

Then bug 156588 is about how "two" addresses on the From line are shown 
differently in the thread pane and in the envelope panel.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.