[Linux] ALT-digit tab-selection shortcuts conflict with accesskey assignments

RESOLVED DUPLICATE of bug 340902

Status

()

P5
normal
RESOLVED DUPLICATE of bug 340902
14 years ago
12 years ago

People

(Reporter: per.angstrom, Assigned: mats)

Tracking

(Blocks: 1 bug, {access, helpwanted, regression})

unspecified
x86
Linux
access, helpwanted, regression
Points:
---
Bug Flags:
blocking-aviary1.0 -
blocking-aviary1.5 -
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
On Linux, the keyboard shortcut for selecting a tab based on its ordinal number
has been changed from CTRL-digit to ALT-digit, in accordance with bug #256635.

Unfortunately, these shortcuts conflict with web pages that use accesskey
attributes, since ALT is also the keyboard modifier for such page-specific
shortcuts. 

How to reproduce:
1) Open a new Firefox window.
2) In the first tab, open <http://www.mozilla.org/>.
3) In a second tab, open <http://diveintomark.org/about/accessibility/>.
4) In the same second tab, press ALT-1.

Expected behavior: Firefox should jump to <http://diveintomark.org/>, in the
same tab.
Actual behavior: Firefox switches to the first tab, showing www.mozilla.org.

See <http://www.w3.org/TR/html401/interact/forms.html#adef-accesskey> for more
information about the accesskey attribute.

Comment 1

14 years ago
That's actually bug 128452, except that you didn't choose the accelerator key
yourself.

Comment 2

14 years ago
*** Bug 264404 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*Sigh*. I looked at this bug after bug 264404 had been a marked a duplicate of
it. And what do I see? Yet more gnomey key binding brain-damage in bug #256635.
Please re-enable Control+number (and also enable Control+Left/Right for
backward/forward). Alt+number (and Alt+Left/Right) have been standard window
manager workspace switching bindings since who knows how long. Make the bindings
easily configurable instead of hard-coded they (at least Alt+Left/Right) seem to
be now.


(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?
Keywords: regression
Summary: [Linux] ALT-digit tab-selection shortcut conflicts with accesskey assignments → [Linux] ALT-digit tab-selection shortcuts conflict with accesskey assignments
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 4

14 years ago
I agree with tpafs.
Since many years (at least) windowmaker uses alt+# to switch desktops, I'm
defnitely not going to change that.
I guess other windowmanagers use different combinations to do that so maybe its
an option to change the modifier-key from the preferences?

Thanks in advance.

Comment 5

14 years ago
Eventually the plan is to make accesskeys use alt+shift+key be the backup for
accesskey combos on Windows and Linux. But, that doesn't help the window mgr
situation.
Blocks: 204402
Component: Disability Access → Keyboard Navigation
Keywords: access
Flags: blocking-aviary1.1?
(In reply to comment #5)
> Eventually the plan is to make accesskeys use alt+shift+key be the backup for
> accesskey combos on Windows and Linux. But, that doesn't help the window mgr
> situation.

Most keyboards today have the Hyper (Windows) key anyway ... I resolved my
conflicts rather effectively using that. All my window manager shortcuts use the
hyper key, so that control and alt are free for the apps ... especially EMACS.
My vote would be to stick to Ctrl+number for the tabs, and Alt+number for the
access keys. Why bend preferences for one particular window manager?

Updated

14 years ago
Keywords: helpwanted
Priority: -- → P5

Comment 7

14 years ago
I'd prefer Ctrl+Number for the tabs and Alt+Number for Accesskeys, too. This was
the behaviour 'til Firefox 0.9 and worked fine.
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 8

13 years ago
Here (Debian testing, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5 (rc3)), both the access key and the tab switching act when I press Alt-1.

Comment 9

13 years ago
I'm seeing the same behaviour as Aleksej. Changing tabs with ALT+<number> switches tab *and* triggers the accesskey link for the old tab.

This would appear to be entirely internal to Firefox - the specific behavious I'm seeing isn't related to window manager shortcuts.

Updated

13 years ago
Flags: blocking-firefox2?
The window mgr situation isn't really fixable, I know people who have both Ctrl+numbers and Alt+numbers bound in their WM, so its just a losing game trying to try to avoid them.
Flags: blocking-firefox2? → blocking-firefox2-

Comment 11

13 years ago
Then maybe there is a way to turn accesskeys off?

Comment 12

12 years ago
> Since many years (at least) windowmaker uses alt+# to switch desktops, 

I recomend using the window (or apple) key as a modifier for all window and desktop management actions. Most keyboards today have these keys. It allows applications to use full range of shortcut combinations and gives an extra space for environment management.

Updated

12 years ago
Assignee: aaronleventhal → mats.palmgren
(Assignee)

Comment 13

12 years ago
bug 340902 fixed the problem reported in comment 0 (content accesskey conflicts
with chrome). I filed bug 345902 regarding tab switching key mask specifically.


*** This bug has been marked as a duplicate of 340902 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.