Closed Bug 26421 Opened 20 years ago Closed 18 years ago

Conn: Changing Open Transport IP stack or Remote Access PPP disconnect disables Moz

Categories

(Core :: Networking, defect, P3, major)

PowerPC
Mac System 9.x
defect

Tracking

()

VERIFIED WORKSFORME
Future

People

(Reporter: masri, Assigned: gordon)

Details

Build ID: 2000012601 (M13)
Platform: Mac PowerBook G3/300, 128Mb RAM, VM off.

I use multiple IP stacks for the various ISPs I use (at the various locations I
use them). I've noticed that if I have Moz running, switch to a different IP
stack, then try to load a new webpage, the Moz logo in the upper right will
flicker for a moment, then stop. Nothing will change on the current page. It's
as if Moz forgets how to talk to Open Transport. The same thing happens if I
disconnect from a Remote Access PPP session, then reconnect.

I believe both these issues are caused by the same underlying bug, which is why
I did not break them out.

- Adam
mac->gordon
Assignee: gagan → gordon
Target Milestone: M15
Target Milestone: M15 → M17
Moving post beta bugs to M18 which is now the post-beta milestone.
Target Milestone: M17 → M18
 ->future
Target Milestone: M18 → Future
This was fixed in bug 49990.  Marking duplicate.


*** This bug has been marked as a duplicate of 49990 ***
Status: NEW → RESOLVED
Closed: 19 years ago
OS: All
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
qa to me:

Adam:

Can you update us, has this improved in recent milestones?
QA Contact: tever → benc
Platform: PowerBook G3/300/192Mb/25Gb, MacOS 9.1
Mozilla Build: 2001080214 (0.9.3)

Using this build, it looks like everything's working fine. I had a non-local
Location Manager setting, launched Mozilla, switched Location Manager to where I
am now, and tried going to a few web pages. Everything's loading as it should.

I'm testing with EtherNET; I can't test from where I am with a dialup. If
somebody else could verify that dialup works (try connecting, launch Moz, load a
web page, disconnect, try loading a different webpage (so the m spins), hit
stop, reconnect, then see if you can load a different (uncached) webpage. I
think that's a pretty harsh test.

- Adam
REOPEN: 
This was duped to the bug about going to sleep. 

+testcase
This is probably the earliest report of disconnect-reconnect not working on dialup.
Status: VERIFIED → REOPENED
Keywords: testcase
Resolution: DUPLICATE → ---
Summary: Changing Open Transport IP stack or Remote Access PPP disconnect disables Moz → Conn: Changing Open Transport IP stack or Remote Access PPP disconnect disables Moz
Works for reporter
Status: REOPENED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → WORKSFORME
Keywords: verifyme
VERIIFED/worksforme.

CFM RIP.
Status: RESOLVED → VERIFIED
Keywords: testcase, verifyme
OS: All → Mac System 9.x
You need to log in before you can comment on or make changes to this bug.