.dmg.bin files handled incorrectly

VERIFIED WORKSFORME

Status

()

Toolkit
Downloads API
--
major
VERIFIED WORKSFORME
14 years ago
10 years ago

People

(Reporter: david brady, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When downloading a file that has a .bin extension, Firefox appears to handle the
file inappropriately. When the download is complete, double-clicking the file
launches StuffIt Expander, but the file is not decoded/expanded, and the DMG
file is not mounted to the Desktop.

Reproducible: Always
Steps to Reproduce:
1. Download a .BIN file from any location (eg.
http://www.microsoft.com/mac/downloads.aspx?pid=download&location=/mac/download/misc/msn_401.xml&secid=35&ssid=4&flgnosysreq=True)
2. When the download is complete, the filename becomes "Messenger401.dmg.bin".
Double-click to decode/expand/mount disk image to Desktop
3. Observe that the file does not decode/expand

Actual Results:  
File is not decoded/expanded

Expected Results:  
File would be decoded/expanded normally. Expected behavior can be observed by
downloading the same file with Safari or Camino.

This does not appear to be an issue with StuffIt or MacOS.

Also, changing the filename to "Messenger401.dmg" does not mount the disk image
properly.

Comment 1

14 years ago
Worksforme using 20040913 Firefox/0.10.1 on Mac 10.3.5.

Comment 2

14 years ago
Works for me
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

I downloaded the file
Once downloaded it opened it from the desktop
It expanded and then the disk image mounted

Are you expecting it to automatically expand and mount when it's done
downloading? As it does in Safari.
(Reporter)

Comment 3

14 years ago
No, I am not expecting it to automount. Automounting is a function of .dmg
properties and is dependent upon how the .dmg was created.

When Firefox downloads a file with a .bin extension, the file cannot be
decoded/decompressed. Double-clicking the file will launch StuffIt Expander, but
the file is apparently corrupted -- StuffIt Expander can neither open, decode,
nor decompress the file.

In other browsers, however, I can double-click the downloaded file and it can be
opened by StuffIt Expander as expected. This occurs in Safari and Camino,
specifically.

Comment 4

14 years ago
Using MacOS X 10.2.8

I have a similar problem, though it turns out to be  Mozilla problem and I'll report it there.

Attempt to download the daily build of Firefox results in a tiny .bin which decompresses into a tiny 
.dmg, which mounts a disk with nothing in it. Using Safari I can download the file just fine and get 
the current build.

Have experienced the problem on:

Firefox V1.0 Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 
Firefox/1.0

-or-

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041221 Firefox/1.0+

-or-

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041227

Comment 5

14 years ago
Please try the following:

Update Mac OS X. (That fixed the problem for me once)
Update Stuffit Expander (Also can fix the problem) http://www.stuffit.com

Please report back with the results.

Still works for me using Mac OS X 10.3.7 and Stuffit Expander 9.01
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a6) Gecko/20041227
Firefox/1.0+
(Reporter)

Comment 6

14 years ago
Updating StuffIt Expander (StuffIt Standard, actually) corrects the problem.
Version 9.0.1 (Build 877) seems to do the trick.

I also updated to Mac OS X (10.3.7) but it appears that StuffIt Expander fixes
the issue on my system.

Comment 7

14 years ago
Resolving as Works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.