copying from ViewSource puts marked-up source in clipboard

RESOLVED INVALID

Status

Core Graveyard
View Source
RESOLVED INVALID
13 years ago
7 years ago

People

(Reporter: Zac Jacobson, Assigned: mrbkap)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

When copying from ViewSource, the selected text is put into the Windows
clipboard in a couple different content types: text/plain and text/html. For the
text/html content type, the clipboard will markup the already-HTML source seen
in ViewSource.



Reproducible: Always
Steps to Reproduce:
1. Select HTML source from ViewSource
2. Paste in a text editor that uses text/html from the clipboard (such as
NetBeans' HTML editor)
3. Notice that the pasted text is not the HTML selected, but markup of that HTML

Actual Results:  
Selecting and copying:
<INPUT TYPE=HIDDEN NAME="delta_ts" VALUE="20040830202042">

puts as text/html in the clipboard:
<html><body>
<!--StartFragment -->
<pre id="line28">&lt;<span class="start-tag">INPUT</span><span
class="attribute-name"> TYPE</span>=<span
class="attribute-value">HIDDEN </span><span
class="attribute-name">NAME</span>=<span
class="attribute-value">"delta_ts" </span><span
class="attribute-name">VALUE</span>=<span
class="attribute-value">"20040830202042"</span>&gt;</pre>
<!--EndFragment-->
</body>
</html>

Expected Results:  
Selecting and copying:
<INPUT TYPE=HIDDEN NAME="delta_ts" VALUE="20040830202042">

puts as text/html in the clipboard:
<INPUT TYPE=HIDDEN NAME="delta_ts" VALUE="20040830202042">

I have opened a but with Netbeans, hopefully there will be a workaround from
that end.. but it seems that the ViewSource behaviour is not correct either, so
I am filing this bug.
(Reporter)

Comment 1

13 years ago
Unfortunately the "Copy Plain Text" extension
http://update.mozilla.org/extensions/moreinfo.php?id=134 is not a workaround as
it doesn't seem to work in ViewSource.

Comment 2

13 years ago
hrm, i've been looking for a way to see the html source for view-source. for the
time being i really don't want this bug fixed because i've been looking for this
leak.

definitely get netbeans to fix their editor :).
The idea is that you should be able to copy/paste the highlighted source out of
viewsource and keep the highlighting if desired (eg by adding a bit of CSS for
those classes).  View-source is no different from any other HTML document.  So
the behavior is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey

Updated

7 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.