runescape.com - No sound in Runescape Java Applet

RESOLVED FIXED in May

Status

Tech Evangelism Graveyard
English US
P3
normal
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: IzzyArgon, Unassigned)

Tracking

unspecified

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

After selecting the resolution for this MMORG, a java applet is loaded into the
browser.  This works fine, except that no sound is ever heard from the game. 
Reported to me by a friend using Firefox on XP Home.

Reproducible: Always
Steps to Reproduce:
1. Go to aforementioned webpage.
2. Select resolution -- large or small does not matter
3. Wait for applet to load all files, including "extra files".  When complete,
there should be sound, but there is not.

Actual Results:  
Applet successfully loaded, but no sound was heard.

Expected Results:  
There should have been sound.

Ordinarily, I would call this a "Normal" bug.  However, since this bug is
stopping at least one person I know of from switching to Firefox (a great
browser, by the way), I have selected "Major" for severity.

Updated

13 years ago
Assignee: bugs → firefox
Component: Web Site → General
QA Contact: firefox.general
I've experimented the same thing

c:\Development>java -version
java version "1.4.2_04"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_04-b05)
Java HotSpot(TM) Client VM (build 1.4.2_04-b05, mixed mode)

Comment 2

13 years ago
I have the same problem in Windows 2000 SP4.  I'm useing Sun Java and I also get
no sound just static.

Comment 3

13 years ago
Yes, I have experienced this too. No sound is loaded on any java applets, not
just runescape.

Comment 4

13 years ago
(In reply to comment #0)

I have this problem also. I believe it is caused by the way Runescape has its
sound. If you view the source of the page, you can see that they make the HTML
play an object(the music, and fx) in the Java. I don't think that is needed. I
think the Java could play the sound, without having that coding in the HTML.

Comment 5

13 years ago
Yes this is bad I think. Firefox should do something about this! :)

Comment 6

13 years ago
Sorry but there is nothing Firefox can do to get sound to work at the site, see
http://www.runescape.com/aff/runescape/faq/techfaq.html. The designers clearly
state that sounds will only work using MS Java. Firefox can only use Sun Java.
MS has not supplied a Netscape (Firefox) compatable plugin for MS Java and MS
Java is no longer getting updated by MS. The designer of the program needs to
write the program for Sun Java.
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Firefox → Tech Evangelism

Comment 7

13 years ago
*** Bug 283507 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
formated summary for tech evang
also see bug 285069 bug 256763 and bug 248640    	
Summary: No sound in Runescape Java Applet → runescape.com No sound in Runescape Java Applet
Summary: runescape.com No sound in Runescape Java Applet → runescape.com - No sound in Runescape Java Applet
Bug 256763 comment 15 indicates that this is something that will be looked into
by the Runescape team.
Assignee: firefox → english-us
Severity: major → normal
OS: Windows Server 2003 → All
QA Contact: general → english-us
Hardware: PC → All

Comment 10

13 years ago
------- Additional Comments From andrew@jagex.com  2005-04-04 01:26 PDT -------
Ok, there are multiple DIFFERENT bugs being reported here, and very confusing.
Only 1 of them is a bug in firefox. Let me clarify

1) Text cursor moves erratical. We do not think this is RuneScape specific
problem. As far as we can tell this is simple a race condition in firefox's
textbox code such that if the computer is at 100% CPU load the text cursors no
longer moves properly. You can reproduce this bug by loading up ANY java applet
that uses 100% cpu and then trying to type into the address bar or any of
firefoxes windows. The reason only some people see this is people with very fast
computer can play runescape without hitting 100% cpu. Write yourselves a simple
test applet that uses several threads to thoroughly eat all the cpu and then
you'll see it happening.

2) The sound doesn't work in RuneScape under firefox. This is NOT a firefox bug.
This is our fault, it's because we are using an IE specific feature to do the
sound because at the time we wrote it Java had no decent midi player. This is on
our list of things to fix, since Java 1.5 finally has an ok midi player. I
repeat this is NOT a firefox bug.

3) The person complaining about getting 2 context menus, when he right clicks in
runescape. Go to Tools->Options->WebFeatures. Click the 'advanced' button next
to 'enable javascript' and tick 'disable or replace context menus'. It will then
work ok. For some reason this javascript option also seems to change the
behaviour of java applets even though, which is technically a bug, or certainly
confusing. But easy to work around.

-------------------

If you notice above, note #2 says that this is known by the runescape team and
they are planning on fixing it..

Someone please mark the bug as wontfix or invalid since it's something JageX,
not the Firefox/Mozilla team, has to fix..
(In reply to comment #10)
> If you notice above, note #2 says that this is known by the runescape team and
> they are planning on fixing it..

If you notice comment 9, I say the exact same thing as you did without
crossposting entire comments.

In any case, this is a tech evangelism bug, so it should remain open for as long
as it takes for the problem to be resolved.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → May

Comment 12

13 years ago
*** Bug 306115 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
(In reply to comment #10)
> ------- Additional Comments From andrew@jagex.com  2005-04-04 01:26 PDT -------
> Ok, there are multiple DIFFERENT bugs being reported here, and very confusing.
> Only 1 of them is a bug in firefox. Let me clarify

May be the sound problem is not a Firefox's bug, but I think Firefox should
still work on the problem and add new functions to "document.app" class and let
HTML play MIDI music. I am saying this because Firefox has been trying so hard
to persuade more and more users to use it by making it compatible to explorer
(Importing bookmarks and stuffs). Ignoring this MIDI problem may make some
people abandant Firfox, when people start to use back IE.

I am just saying, that improvement is always good. If I am the programmer who
write Firefox, I would be happy to see it, in any way, better then all other
browers. I like Firefox very much and so I hope it improve.

Comment 14

12 years ago
This has been fixed by the Runescape team today! Hooray :)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.