div block using clear:both aligns to float blocks outside container block (regression)

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: berarma, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8a4) Gecko/20040927

In the given URL you can see part of the central column shifted down below the 2
float columns at both sides. It's a div with the clear property set. It's inside
a container block that flows between the 2 floats so I guess it shouldn't happen
this. As a matter of fact this worked well until v1.8a2. With mozilla1.8a1 I can
still see the page correctly.

Reproducible: Always
Steps to Reproduce:
1. enter http://bandaoliva.dynalias.net
2. see the flow of the middle column.
3.

Actual Results:  
Part of the middle column is shifted to the end of the page below the sidebars
leaving an empty space.

Expected Results:  
Flow the middle column without the empty space.

(REGRESSION) It's important since it breaks currently working pages.
(Reporter)

Comment 1

14 years ago
Just checked IE5.5 and IE6.0 do the same. Wondering if that's the correct
behaviour. I've changed the page at the given URL to make it look better. I'll
post another URL if necessary to better show the problem (if any).
From the description, our behavior sounds correct (and there was a bug fix
recently).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.