Closed Bug 264386 Opened 20 years ago Closed 19 years ago

Older version entries in registry not removed when version changes

Categories

(SeaMonkey :: Installer, defect, P2)

x86
Windows XP
defect

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey1.0alpha

People

(Reporter: lohphat, Assigned: masayuki)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041014
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041014

[HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla] contains references to older versions
which should have been removed when newer version installed.

Reproducible: Always
Steps to Reproduce:
See desc. and attachment https://bugzilla.mozilla.org/attachment.cgi?id=161575

Actual Results:  
older version entries not removed

Expected Results:  
removed the entries
WFM on WinNT4. Only the installed versions are in my registry. I always use the
uninstaller to uninstall installer versions.
Product: Browser → Seamonkey
*** Bug 284071 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #1)
> WFM on WinNT4. Only the installed versions are in my registry. I always use the
> uninstaller to uninstall installer versions.

i never uninstall manually, just install a new version, and that installer does
the job, but not completely well, it seems.
*** Bug 294357 has been marked as a duplicate of this bug. ***
I marked bug 294357 as duplicate of this one, but you should still have a look
on it if you are going to solve it.
Attached patch Patch rv1.0Splinter Review
Assignee: general → masayuki
Status: NEW → ASSIGNED
Attachment #184018 - Flags: superreview?(bzbarsky)
Attachment #184018 - Flags: review?(benjamin)
Comment on attachment 184018 [details] [diff] [review]
Patch rv1.0

(dveditz might be a better sr for this patch)
Attachment #184018 - Flags: review?(benjamin) → review+
Comment on attachment 184018 [details] [diff] [review]
Patch rv1.0

Oops. Sorry. I missed superreviewer.
Attachment #184018 - Flags: superreview?(bzbarsky) → superreview?(dveditz)
Attachment #184018 - Flags: approval1.8b2?
Comment on attachment 184018 [details] [diff] [review]
Patch rv1.0

not blocking 1.8b2
Attachment #184018 - Flags: approval1.8b3?
Attachment #184018 - Flags: approval1.8b2?
Attachment #184018 - Flags: approval1.8b2-
Comment on attachment 184018 [details] [diff] [review]
Patch rv1.0

Please re-request approval after dveditz' review.
Attachment #184018 - Flags: superreview?(dveditz)
Attachment #184018 - Flags: review?(dveditz)
Attachment #184018 - Flags: approval1.8b3?
Attachment #184018 - Flags: review?(dveditz) → superreview?(dveditz)
Flags: blocking-seamonkey1.0a?
Priority: -- → P2
Target Milestone: --- → Seamonkey1.0alpha
Comment on attachment 184018 [details] [diff] [review]
Patch rv1.0

sr=dveditz
Attachment #184018 - Flags: superreview?(dveditz) → superreview+
Comment on attachment 184018 [details] [diff] [review]
Patch rv1.0

The risk is low.
Attachment #184018 - Flags: approval1.8b3?
Attachment #184018 - Flags: approval1.8b3? → approval1.8b4+
checken-in.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Flags: blocking-seamonkey1.0a?
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: