incomplete url when clicking on previous sites in the address bar

RESOLVED DUPLICATE of bug 274135

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 274135
13 years ago
12 years ago

People

(Reporter: dan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

after typing a partial url, such as "www.mozil" and then the previous sites list
appears below, clicking on a complete entry, like "www.mozilla.com" doesn't load
the full url, only the partially entered one.

Reproducible: Sometimes
Steps to Reproduce:
1. type www.mozzi (or a site you've visited. i take it you've visited your own
site.)
2. click the complete entry (www.mozilla.com)

Actual Results:  
only the partially entered url loaded. (www.mozi)

Expected Results:  
load the full url.

Comment 1

13 years ago
This can be reproduced fairly reliably by:

1) Go to any site (helps to pick one that doesn't load instantly)

2) Wait for site to load.  In a short period after the throbber stops going
round, click the adress bar to highlight the URL

3) Immediately type the first letter of a previous URL that will register with
autocomplete

4) Immediately click one of the entries in the dropdown

The browser will often then act as if you'd just entered what you typed, in many
cases doing a search for the first letter(s) of the URL and fetching a
completely unrelated page.

Comment 2

13 years ago
see :
https://bugzilla.mozilla.org/show_bug.cgi?id=274135
and
https://bugzilla.mozilla.org/show_bug.cgi?id=168623
(Reporter)

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 274135 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.