Closed Bug 26439 Opened 25 years ago Closed 22 years ago

Need to improve "Personal Namespace" on advance IMAP preference

Categories

(MailNews Core :: Backend, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: huang, Assigned: naving)

Details

02-03-10-M14 mozilla build:
Now, from bug#19248, we can see the UI display for advance IMAP for personal 
namespace.
when verifying bug#24715, the prefs.js still display "\"Inbox.\"" instead of 
"Inbox."
We need to improve that inorder to bring the "Inbox." from 4.7 to 5.0.
Change QA contact to me.
QA Contact: lchiang → huang
Reassign to jefft, cc alecf.
Assignee: phil → jefft
CC'ing sspitzer, this might be a migration issue.
I think migration does the right thing. In the pref we still stored as 
"\"Inbox.\"" why we did this way? I don't know. Chris Fuchs implemented this a 
while back. I don't know if there is an easy way to not having the extra double 
quotes.
Status: NEW → ASSIGNED
Target Milestone: M14
Target Milestone: M14 → M17
Moving to M18 and nominating for beta3.
Keywords: nsbeta3
Target Milestone: M17 → M18
Karen - is there any harm if we don't fix this?
Since migration does bring the "Inbox." value for IMAP Cyrus "Personal 
Namespace" on UI. So I think that will be fine for not fixing prefs.js file for  
beta3. Removing nsbeta3 for the keywords, let developers to decide the target 
milestone.
Keywords: nsbeta3
Target Milestone: M18 → Future
reassigning jefft's bugs to naving
Assignee: jefft → naving
Status: ASSIGNED → NEW
Blocks: 27002
Ccing Cavin. 
Since this bug blocked bug 27002 and bug 27002 has been nominating nsbeta1. So 
this bug should be in nsbeta1 for next release.....
Keywords: nsbeta1
Keywords: nsbeta1nsbeta1-
CC to myself.
This is not a bug.
2 reasons:
1. The imap server may support more than one "Personal Namespace"(also it can
support more than one "Public Namespace" and "OtherUsers Namespace"). By using
"\"", mozilla may successfully read the whole settings string instead part of
it. Because they are seperated by ",". Following is from my preference(a UW V4R1
IMAP server).
user_pref("mail.server.server4.namespace.other_users", "\"~\"");
user_pref("mail.server.server4.namespace.personal", "\"#mh/\",\"#mhinbox\",\"\"");
user_pref("mail.server.server4.namespace.public",
"\"#public/\",\"#news.\",\"#ftp/\",\"#shared/\"");
2. In the current implementation of mozilla, "" stands for there is not such a
namespace(See the followings from my preference.), otherwise, "\"\"" stands for
there is a namespace "".
user_pref("mail.server.server5.namespace.other_users", "");
user_pref("mail.server.server5.namespace.personal", "");
user_pref("mail.server.server5.namespace.public", "");

Mark this bug WONTFIX.

Another thing, this bug should not block bug 27002 which can be solved
seperately. So, clear the "blocks" area.
No longer blocks: 27002
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WONTFIX
Hi, Karen Huang, please verify. Thanks.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.