Blocking popups that are not bad.

RESOLVED DUPLICATE of bug 272389

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 272389
14 years ago
13 years ago

People

(Reporter: Thom McVeigh, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a5) Gecko/20041013 Camino/0.8+
Build Identifier: Camino 2004101308 (v0.8+)

Javascript bookmarks like the blogger 'blog this' are unable to create windows
due to pop up blocking. 

Reproducible: Always
Steps to Reproduce:
1.Click the link I gave

Actual Results:  
Pop up blocking icon appears in bottom left corner of browser

Expected Results:  
A window should have popped up, after all it wasn't the site requesting it, it
was me.
(Reporter)

Comment 1

14 years ago
Just noticed after clicking on the URL link right above, that it works as
desired when clicked on a page. Drag the URL to your bookmark bar, and it ceases
to function as desired. 
(Assignee)

Comment 2

14 years ago
i imagine this fails with ff too, right?
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> i imagine this fails with ff too, right?

Works for me under Firefox 0.10 

Comment 4

14 years ago
Confirming with Camino 2004101608 using 10.3.5.
It didn't work using a bookmark or in the location bar.

The popup icon shown says the popup is from the current page and gives me the
option to unblock bugzilla.mozilla.org.

Comment 5

14 years ago
Confirmed using 2004101408 (v0.8+) NB on 10.3.5

Apperently we are doing something to much. I'm going to look into our popup prefs.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

14 years ago
Ok this is the info I have now. Our current popup block implementation is very
naive compared to the FF settings.

Camino popup prefs:
dom.disable_open_during_load -> true

Firefox uses:
dom.popup_allowed_events -> change click dblclick mouseup reset submit
dom.popup_maximum -> 20
privacy.popups.firstTime -> false
privacy.popups.policy -> 1
privacy.popups.usecustom -> true
Summary: javascript bookmarks are being blocked by pop up blocking → Blocking popups that are not bad.

Comment 7

14 years ago
Ok some more info.

if you open a blank new window that doesn't have any page loaded yet, the
javascript popup works from the bm toolbar. But as soon as a page is loaded
Camino blocks the popup.
(Assignee)

Comment 8

13 years ago
i have a fix for this over in 272389. it was a regression from the popup blocker
rewrite jst did.

*** This bug has been marked as a duplicate of 272389 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.