Browsing category at Mozilla Update doesn't stay in that category

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: Harry, Assigned: wolf)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

The navigational links within a particular category at update.mozilla.org are
missing the "category" argument for showlist.php.  This makes navigating within
a particular category with multiple pages, such as "Popular", "Top Rated", and
Newest" impossible withing manually adding the "category" argument to the page link.

Reproducible: Always
Steps to Reproduce:
1. Go to http://update.mozilla.org/extensions/.
2. Pick a category that has multiple pages such as "Popular", "Top Rated", or
"Newest"
3. Within the category click the "Next" link or one of the "Jump to" page number
links.

Actual Results:  
After clicking the "Next" link or one of the "Jump to" links instead of staying
in the category you picked you are taken out of that category into the "All"
category.

Expected Results:  
Clicking the "Next" or "Jump to" links within a category should stay in that
category.  The page navigation links within that category need the "category"
argument to be added in addition to the "pageid" argument.
(Assignee)

Comment 1

13 years ago
WFM. Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913
Firefox/0.10.1

Don't block cookies from update.mozilla.org. ;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

13 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> WFM. Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913
> Firefox/0.10.1
> 
> Don't block cookies from update.mozilla.org. ;-)

That worked back when you and also someone else suggested it to me.  Lately I've
noticed that the OS detection seems somewhat erratic.  Even though I'm using
Linux and that's reported in the user agent string by Firefox, Windows seems to
be selected.

When I look up the "Page View" category the by the menu on the left Windows is
selected.  The next page in that category switches to MacOSX for the OS.  This
is related to this bug since when I try and pick the category of "Linux" myself
it changes the category to All.  I have cookies available and have seen this
problem on several different distributions using different installs of Firefox.
     Is the reason for this that the site is undergoing change at the moment?
(Assignee)

Comment 3

13 years ago
That's probably Bug 269343. After the Firefox 1.0 release, update.mozilla.org
got moved behind some cache servers to help with load and availability. There's
some issues with detection as a result. 
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.