Force links that open new windows with height/width to open in iframe in new tab

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: zarco.zwier, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041012 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041012 Firefox/0.10

If "Force links that open new windows to open in" is set to "new tab", popups
with specified sizes are opened in a new tab, but their size is disregarded.
I'd suggest to put these popups in an iframe with the specified sizes.

Reproducible: Always
Steps to Reproduce:
1. Go Options - Advanced
2. Under tabbed browsing: set "Force links that open new windows to open in" to
"new tab". Click OK
3. Go to http://www.tweakers.net
4. Go to My TNET - Inloggen

Actual Results:  
A new tab is opened, but the specified size are ignored.

Expected Results:  
Open a new tab and put the contents of the popup in a iframe with a visible border.
(Reporter)

Updated

14 years ago
Severity: normal → enhancement
many pages check if they are the top window and reload the page in the page
containing the iframe or frame

INVA ?
(Reporter)

Comment 2

14 years ago
> many pages check if they are the top window 
> and reload the page in the page containing the iframe or frame

Don't completely understand what you're trying to say here and how it relates to
my enhancement request...
Could you explain your comment?

Comment 3

14 years ago
1) An iframe is a different JavaScript window object than its container window.
For script compatibility, loading the requested window into an iframe would
require that we return the iframe window, not the outermost window, from the
window.open call. This returned window object is shared by content script and
program code. It would probably be safe enough to fix the program code to not
make the assumption that it's been given the outermost window, but I fear
repercussions.

2) The change could cause problems with website script. It's easy to imagine a
window that itself contains frames, and script that belongs to a frame and
refers to properties in its parent window but uses the property window.top to do
so, because it makes the assumption that the overall window structure is as the
window was designed to be. Inserting such a window into an unexpected iframe
would make the frame's window.parent no longer the same object as window.top,
and break website script. It shouldn't be surprising that I can't think of a
live example right now, but you know there are such sites.

3) If the opened window happens to be sized larger than the user's current
window, the proposed modification would be of no help.

4) An pref named |browser.link.open_newwindow.restriction| can be used to except
windows with a "feature" argument, including sized windows, from being opened
into tabs at all. See bug 172962 comment 155.

The benefit provided by the suggested change is merely a visual refinement. It
won't work in all cases (though agreed it would probably help in most cases) and
it implies a range of side effects ranging in impact from worrisome to broken.
Further, there is a workaround that, while it functions wholly differently,
arguably provides the desired effect. Closing won't fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

14 years ago
Would it be better if not an iframe were to be created, but borders made with xul?
A xul frame larger that the containing window could be given the size of the
containing window.
You need to log in before you can comment on or make changes to this bug.