Firefox startup dumps random text to console

RESOLVED FIXED in mozilla1.8rc1

Status

()

Toolkit
Add-ons Manager
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: bz, Assigned: nthomas)

Tracking

({fixed1.8})

1.8.0 Branch
mozilla1.8rc1
fixed1.8
Points:
---
Bug Flags:
blocking1.8rc1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

BUILD: 0.10.1 or 2004-10-14-21 branch Firefox nightly on Linux.

STEPS TO REPRODUCE:
1)  Make sure you have no firefox profile
2)  Start Firefox
3)  Select any option in the import dialog (well, I tried "don't import
    anything" and importing NS4 and Mozilla 1.x profiles).

ACTUAL RESULTS:  xterm where you started Firefox shows:

*** nsExtensionManager::_disableObsoleteExtensions - failure, catching exception
so finalize window can close
*** loading the extensions datasource
*** loading the extensions datasource

In addition, when importing the SeaMonkey profile, it shows:

*** started
*** before 1
*** after 16
*** before 64
*** after 64
*** before 32
*** after 32
*** done

during the import itself.

EXPECTED RESULTS:  Don't output debug information to console in a release build.
Version: Trunk → 1.0 Branch
Note that these are dump() statements.  I have no idea why they are getting
dumped.  My Mozilla profile does have dump enabled, but that should not affect
the "no import" or "import from NS4" cases.
(Assignee)

Comment 2

12 years ago
Created attachment 199657 [details]
Extension Manager console output

There is quite alot more console output in 1.5b2, with the Extension Manager
printing 12 lines the first time a new profile is used, and at least 8 lines on
each check for extension updates. (I modified <firefox install>/ components/
nsExtensionManager.js#480 so that dump uses ***nsExtensionManager*** to prefix
instead of ***, uniquely identifying the source of the messages).

Patch for this, and the migration dump()'s, coming up.
(Assignee)

Updated

12 years ago
Flags: blocking1.8rc1?
(Assignee)

Comment 3

12 years ago
Created attachment 199663 [details] [diff] [review]
Leverage the default pref for extensions.logging.enable

This patch uses the variable gLoggingEnabled for all Extension Manager messages
rather just the single case. It relies on the default value for the preference
extensions.logging.enabled being set to false in firefox/thunderbird.js, which
is currently the case, and therefore only affects new profiles.

I tried to suppress dump() using browser.dom.window.dump.enabled, but the
Extension Manager does not seem to have access to the preferences from the
profile it is manipulating.

Updated

12 years ago
Flags: blocking1.8rc1? → blocking1.8rc1-

Updated

12 years ago
Attachment #199663 - Flags: review?(robert.bugzilla)
(Assignee)

Comment 4

12 years ago
A correction to my previous comment, this patch works for all profiles because
the default pref applies unless the profile overrides.
Comment on attachment 199663 [details] [diff] [review]
Leverage the default pref for extensions.logging.enable

Sorry it took so long to get to this - looks good.
Attachment #199663 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 6

12 years ago
Is superreview required ? If not, could Rob or Benjamin land this on the trunk
in preparation for asking for approval1.8rc1+.

Comment 7

12 years ago
Comment on attachment 199663 [details] [diff] [review]
Leverage the default pref for extensions.logging.enable

Looks good to me too.  I think we should definitely take this for 1.5 as it
makes our Linux build look extremely unpolished when run from the command line.
Attachment #199663 - Flags: superreview+
Attachment #199663 - Flags: approval1.8rc1?
Assignee: bugs → nrthomas
OS: Linux → All
QA Contact: bugs → extension.manager
Hardware: PC → All
Version: 1.0 Branch → 1.5 Branch

Updated

12 years ago
Attachment #199663 - Flags: approval1.8rc1? → approval1.8rc1+

Comment 8

12 years ago
The second hunk of this patch removes a check for gLoggingEnabled.  Is that
because the check is unnecessary in that page?
It isn't necessary since gLoggingEnabled has been added to the LOG function

 function LOG(string) {
-  dump("*** " + string + "\n");
+  if (gLoggingEnabled)  
+    dump("*** " + string + "\n");
   gConsole.logStringMessage(string);
 }

Comment 10

12 years ago
This is fixed on trunk and the 1.8 branch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Target Milestone: --- → Firefox1.5rc1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.