mbox "From " line datestamp non-portable between time zones

RESOLVED WONTFIX

Status

MailNews Core
Database
RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: jwq, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040616

 When an email is written to an mbox file, the "From " message delimiter line is
datestamped with the current time. According to the mbox man page
<http://www.qmail.org/man/man5/mbox.html> this datestamp should be in GMT:

     The delivery date in a From_ line does not specify a time
     zone. qmail-local always creates the delivery date in GMT
     so that mbox files can be safely transported from one time
     zone to another.

MailNews is currently writing the datestamp in the local time zone, without
explicitly specifying that time zone, thus rendering the datestamp non-portable
between time zones.

 Note that this datestamp and its reliability could be important because it
might be used as part of the solution to a number of bugs requesting or
requiring a received-locally datestamp: Bug 123786; Bug 166254; Bug 190337 and
Bug 200802.

 This problem with the "From " message delimiter datestamp could be fixed by either:

   1. Following the mbox spec cited above and writing the 
      datestamp in GMT but without specifying the time zone,

or 2. Explicitly specifying the time zone offset at the 
      end of the datestamp.

(1) has the advantage of adhering to the mbox "spec" but the disadvantage of
ambiguity. (2) has the advantage of explicitly specifying the date, but the
disadvantage of ignoring the mbox "spec" (the world doesn't need another
non-"standard" mbox implementation).

 I'm in two minds as to the best choice, but would tend to favour (1). I'd like
to hear other opinions.

Reproducible: Always
Steps to Reproduce:
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 2

12 years ago
I believe this bug is still present. Could someone please confirm?
(Reporter)

Comment 3

12 years ago
David, is "Core, MailNews: Database" the most appropriate Product and Component for this bug?
QA Contact: database
Product: Core → MailNews Core

Comment 4

9 years ago
> Note that this datestamp and its reliability could be important because it
> might be used as part of the solution to a number of bugs requesting or
> requiring a received-locally datestamp: Bug 123786; Bug 166254; Bug 190337 and
> Bug 200802.

Actually, the date in the mbox-"From" header line is the time of the download, not the time the message was received at the server. Thus, I doubt that it should be used for the bugs mentioned here as a sorting criteria. Rather, the last "Received:" header (i.e., the first entry when parsing the message) should be considered relevant as sorting criteria for the message received, not the order in which the messages were downloaded and stored.

Thus, I'm not sure whatever other relevance I would give that time stamp and in which context - other than just informational - it should be used.
(Assignee)

Comment 5

9 years ago
yes, it's basically not used
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.