Ctrl-Shift-W Closes Window & All Open Tabs Without Confirmation

RESOLVED DUPLICATE of bug 250983

Status

()

--
major
RESOLVED DUPLICATE of bug 250983
14 years ago
13 years ago

People

(Reporter: mozilla-bugs, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I had around 10 tabs open and in Tools > Options > Advanced > Browsing I had
ticked 'Warn when closing multiple tabs'.  On one of may tabs I had composed a
long blog post which I was about to submit.  Suddenly by accident I pressed
Ctrl-Shift-W instead of Shift-W and to my shock and horror the entire window
closed without any sort of confirmation and as a result I lost all my work! 
This is not an enhancement request.  It is a serious problem that misleads the
user.  Please give it due attention.  Many thanks.

Reproducible: Always
Steps to Reproduce:
1.  Turn on 'Warn when closing multiple tabs' option.
2.  Open lots of tabs in a window.
3.  Type a long passage in a web form for about an hour.
4.  Press Ctrl-Shift-W accidentally instead of Shift-W.
5.  Watch your work disappear into a black hole.
Actual Results:  
Firefox quit without confirmation.

Expected Results:  
It should provide confirmation.
(Reporter)

Comment 1

14 years ago
The funny thing is I was actually writing about Mozilla Firefox 1.0 PR when this
happened.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20041015
Firefox/0.10

->DUPE or was part of another bug ?

this has been fixed (couldn't find the bug)

Comment 3

14 years ago
bug 250983, fixed four days ago.

*** This bug has been marked as a duplicate of 250983 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.