suntrust.com - CheckFree Billpay bad sniffing, feeds broken CSS to non-Firefox Gecko browsers

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
--
major
RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: Kevin Roberts, Unassigned)

Tracking

({ecommerce})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Bill Pay service from SunTrust bank (provided by CheckFree corporation) no
longer supports Firefox. Confirmed with SunTrust they recently upgraded their
Bill Pay service. Now if you click on Bill Pay link from Online Banking page you
get web page saying browser is not currently supported, and recommends using IE,
Netscape, Safari or AOL! Contacted tech support for CheckFree and confirmed they
do not support Firefox. 

Reproducible: Always
Steps to Reproduce:
1. Log into SunTrust online banking
2. Click on Pay Bills link
3.

Actual Results:  
Get web page saying:
<SunTrust logo>
The browser you are using is not currently supported by Bill Pay. For best
results and to ensure accuracy, we
recommend you use one of the following supported browsers:

# Microsoft Internet Explorer 5.5 or later
# Netscape Navigator 6.2 or later
# Apple Safari 1.2
# AOL 9.0


If you would like to upgrade your browser now, select one of these links to the
appropriate site for a download of the upgrade.

Expected Results:  
Take me to Bill Pay service provided by CheckFree corporation. Worked fine the
last time I used it (before recent upgrade to service by SunTrust). Note that
CheckFree has confirmed that it is they who do not support Firefox.

This is a major problem since it prevents me and all other Firefox users from
using our most secure browser for financial transactions!

Note that if you go to SunTrust URL above, and click on the Browser Test button,
you will get the following (different) error message:

You are currently using the following browser:

Netscape 5.0 (Windows; )

For optimal performance, we recommend that you use one of the following 128-bit
encrypted browsers:

    * Internet Explorer 5.5 or higher
    * AOL 7.0
    * Netscape 4.79 or higher

Comment 1

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new

Reporter, when you file a TE bug, please follow the reporting guidelines.
Blocks: 124594
Summary: CheckFree corporation no longer supports FireFox → suntrust.com - CheckFree corporation no longer supports FireFox

Comment 2

14 years ago
*** Bug 264695 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
Not win only.

I called SunTrust to complain. After useless talking with normal support staff,
I asked for someone "higher up the food chain" and was given Adam Boutillette.
He reiterated the information submitted in comment 0, but said he would submit a
request to the web technical team to support Mozilla, and snail mail me a CC.

STI http://www.pcquote.com/stocks/quote.php?symbol=sti is the largest regional
bank doing business in Florida.

If this isn't quickly fixed, I will file a complaint as an STI stockholder.
Keywords: ecommerce
OS: Windows XP → All
Hardware: PC → All

Comment 4

14 years ago
After first talking on the phone this AM with both, I separately emailed
sue.chaffin@suntrust.com in SunTrust web banking support (800-382-3232) and
jennifer.sekelchurch@suntrust.com in STI investor relations (404-230-5392)
explaining:

1-Recommending downgrade to old, insecure and bug ridden web browsers pushes
astute customers to competitors
2-Web standards compliance means virtually all customers are securely welcomed
3-Netscape is (an older) Mozilla
4-Links to various supporting web resources that explain Mozilla, standards,
security, etc

For SunTrust TE history, see bug 73894
Summary: suntrust.com - CheckFree corporation no longer supports FireFox → suntrust.com - CheckFree corporation no longer supports FireFox or Mozilla

Comment 5

13 years ago
Problem remains unchanged even in FF 1.0.1.

Comment 6

12 years ago
Coming up on two years later, and they still don't get it. The message is unchanged, so SeaMonkey isn't supported either.
Summary: suntrust.com - CheckFree corporation no longer supports FireFox or Mozilla → suntrust.com - CheckFree corporation does not support FireFox, Mozilla or SeaMonkey

Comment 7

12 years ago
*** Bug 355882 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 367687
(Reporter)

Comment 9

11 years ago
As soon as I noticed tonight that SunTrust has upgraded their online bill pay service I switched from IE to see if the bill pay service now works in Firefox. It appears that it does!

Comment 10

11 years ago
Gecko is no longer locked out, but the site behaves unacceptably when a minimum font size is applied. The left column gets partially lost underneath the right column when I make the text big enough to read, making it impossible to use with their site styles applied. I can only use it by disabling the site styles.

I called to complain about the missing pay date field and partially missing payment amount field and was told that IE, Safari and Netscape remain the only supported browsers, that Firefox is "unstable on our site", and that fixing it to work with Firefox is on the wishlist.

I told the rep that Netscape now is Firefox, but she wouldn't change her reponse.

Comment 11

10 years ago
Comment 10 is definitely NOT the same bug as was originally filed and should be filed as a separate bug.

It sounds very much like the original bug is FIXED, at least in Firefox, but in order to confirm for certain that it's totally fixed, we need people who have the ability to test this to test it in Seamonkey and/or Camino (or even a Minefield nightly). Felix and Kevin, can you guys look into that?
(Reporter)

Comment 12

10 years ago
I agree that comment 10 should be filed as a separate bug as it is dealing with a separate issue.

FI: Yes, increasing the font size in Firefox 2.x/Windows (with Ctrl-+) screws up the display, but leaving it in the default font size it looks fine.

I checked it out on Camino and the Billpay page looked completely off even in the default font size. In Camino it appeared to not nest the data inside the background, but displayed the data columns to the right of the background.



Comment 13

10 years ago
This bug was and remains about bad sniffing, which is not yet fixed, but merely improved. Currently loaded in Firefox 2.0.0.14 and SeaMonkey 1.1.9 is the following:
<script>
var detect = navigator.userAgent.toLowerCase();
if(detect.indexOf("firefox") > -1)
{
document.write('<link rel="stylesheet" media="screen" type="text/css" href="/cwp411/build/static_imp/2801/cf_win_firefox_1.css?cfwver=20071107-CFWEB411">');
}
</script>
Blocks: 334967
Summary: suntrust.com - CheckFree corporation does not support FireFox, Mozilla or SeaMonkey → suntrust.com - CheckFree Billpay bad sniffing

Comment 14

10 years ago
Thanks for digging into that more, Felix and Kevin. That certainly explains why the page is totally messed up in Camino in comment 12.

Kevin, what version of Camino did you use? Versions 1.6 and later have "not Firefox" as part of their UA string and should pass the "test" in comment 13.
Summary: suntrust.com - CheckFree Billpay bad sniffing → suntrust.com - CheckFree Billpay bad sniffing, feeds broken CSS to non-Firefox Gecko browsers
(Reporter)

Comment 15

10 years ago
Sorry. You are right. The version of Camino I originally tested was "2006021400 (1.0)" and on a computer I do not normally use.

I upgraded Camino to "1.6 (1.8.1.14 2008040922)" and the billpay page looked as it should.
Now redirected to https://www.suntrust.com/PersonalBanking
No apparent issues. The site must have changed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME

Comment 17

4 years ago
The only site change I see is bill pay works in SeaMonkey now. The URL provided here was only ever a stepping stone to the private, personal logged in URL.
You need to log in before you can comment on or make changes to this bug.