Last Comment Bug 264621 - Firefox pa-IN (punjabi) l10n CVS account-Amanapreet Singh Alam<amanpreetalam@yahoo.com>
: Firefox pa-IN (punjabi) l10n CVS account-Amanapreet Singh Alam<amanpreetalam@...
Status: RESOLVED FIXED
voucher, sshkey
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
: Daniel (Leaf) Nunes
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 00:13 PDT by A S Alam
Modified: 2005-04-28 08:39 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ssh key (656 bytes, application/zip)
2004-10-16 00:14 PDT, A S Alam
no flags Details
firefox lang folder, I picked the en-US.jar folder, then make pa-IN.zip (146.45 KB, application/zip)
2004-10-16 00:18 PDT, A S Alam
no flags Details
firefox lang folder, I picked the help.jar folder, then make help.zip by translating every thing (94.59 KB, text/plain)
2004-10-16 00:19 PDT, A S Alam
no flags Details
Firefox from CVS is in Punjabi, where all files are put, but CVS directory as it is (275.99 KB, text/plain)
2004-11-16 20:43 PST, A S Alam
no flags Details
This is Taken from Main CVS for Firefox. (105.86 KB, application/zip)
2004-11-16 20:44 PST, A S Alam
no flags Details
Update mozilla folder from CVS there is bwoser + Toolkit (272.53 KB, application/octet-stream)
2004-12-04 03:18 PST, A S Alam
no flags Details
mozilla/browser/locales/pa-IN/defines.inc files (365 bytes, text/plain)
2004-12-05 22:51 PST, A S Alam
no flags Details
revert this patch to get the pa-IN installer files (which don't work due to charset) (25.86 KB, patch)
2005-02-09 06:41 PST, Axel Hecht
no flags Details | Diff | Splinter Review
/l10n-aviarybranch/ toolkit/ locales/ pa-IN/ chrome/ mozapps/ update/update.properties (4.14 KB, text/plain)
2005-03-03 17:52 PST, A S Alam
no flags Details
update file for error chrome/pa-IN/locale/browser/browser.dtd (19.05 KB, text/plain)
2005-03-20 23:47 PST, A S Alam
no flags Details

Description A S Alam 2004-10-16 00:13:08 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

I translate the firefox into Punjabi Language (pa-IN) version 1.0 PR

I want to add pa-IN locale to Mozilla cvs,

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 A S Alam 2004-10-16 00:14:26 PDT
Created attachment 162275 [details]
ssh key
Comment 2 A S Alam 2004-10-16 00:18:31 PDT
Created attachment 162276 [details]
firefox lang folder, I picked the en-US.jar folder, then make pa-IN.zip
Comment 3 A S Alam 2004-10-16 00:19:35 PDT
Created attachment 162277 [details]
firefox lang folder, I picked the help.jar folder, then make help.zip by translating every thing
Comment 4 A S Alam 2004-10-16 00:24:01 PDT
http://www.geocities.com/amanpreetalam/firefox.png

you can also check the firefox in Punjabi Language

Comment 5 Marcia Knous [:marcia - use ni] 2004-10-22 15:13:04 PDT
Haven't seen a CVS form come thru yet - www.mozilla.org/hacking/form.html.
Comment 6 Marcia Knous [:marcia - use ni] 2004-11-10 13:26:10 PST
Confirming receipt of CVS form - hard copy.
Comment 7 Benjamin Smedberg [:bsmedberg] 2004-11-10 13:38:00 PST
Amanpreet, these files are not in the correct format for CVS localizations.
Please take a look at the directory structure at

http://lxr.mozilla.org/aviarybranch/source/toolkit/locales/
http://lxr.mozilla.org/aviarybranch/source/browser/locales/
Comment 8 A S Alam 2004-11-16 20:43:18 PST
Created attachment 166191 [details]
Firefox from CVS is in Punjabi, where all files are put, but CVS directory as it is
Comment 9 A S Alam 2004-11-16 20:44:53 PST
Created attachment 166192 [details]
This is Taken from Main CVS for Firefox.
Comment 10 Benjamin Smedberg [:bsmedberg] 2004-12-02 07:06:40 PST
Gandalf, can you review this?
Comment 11 Zibi Braniecki [:gandalf][:zibi] 2004-12-02 07:33:11 PST
sure. reviewing
Comment 12 Zibi Braniecki [:gandalf][:zibi] 2004-12-03 17:16:48 PST
review:
1) I don't know punjabi but it looks that Help is not translated...
2) Please, translate ./browser/defines.inc and use own uuid
3) ./toolkit/locales/installer/windows/charset.mk - i dubt punjabi uses CP1252
but i might be wrong here
4) Many parts of ./toolkit are not translated yet
5) use Unix like line endings.
Comment 13 A S Alam 2004-12-04 02:35:46 PST
(In reply to comment #12)
> review:
> 1) I don't know punjabi but it looks that Help is not translated...
After cheching out from CVS
http://lxr.mozilla.org/aviarybranch/source/toolkit/locales/
http://lxr.mozilla.org/aviarybranch/source/browser/locales/
I am not able for find Help.


> 2) Please, translate ./browser/defines.inc and use own uuid
Can you please give some info about uuid, I asked some many times on the #l10n
chanel, but not got answer, what actual to do with this file. remove # or not

> 3) ./toolkit/locales/installer/windows/charset.mk - i dubt punjabi uses CP1252
> but i might be wrong here
Where I can find this info in Windows.
> 4) Many parts of ./toolkit are not translated yet
I completed again. Attaching again

> 5) use Unix like line endings.
any problem with that. How Can I remove that.
Comment 14 A S Alam 2004-12-04 03:18:01 PST
Created attachment 167825 [details]
Update mozilla folder from CVS there is bwoser + Toolkit
Comment 15 Zibi Braniecki [:gandalf][:zibi] 2004-12-04 10:20:41 PST
Amanpreet:
1) http://lxr.mozilla.org/aviarybranch/source/toolkit/components/help/locale/en-US/
2) Since Langpack is an extension, you have to generate unique ID for Your
localization. On any unixlike machine You have "uuidgen" app which do this. I
don't know how does it looks on windows, but google will know probably
3) In google
http://www.kostis.net/charsets/
http://www.dataparksearch.org/dpsearch-international.en.html
http://www.columbia.edu/kermit/charsets.html
5) google again - http://www.thefreecountry.com/tofrodos/index.shtml
Comment 16 Benjamin Smedberg [:bsmedberg] 2004-12-04 10:22:26 PST
Localizations of 1.0 are not required to translate the help system, if they do
not have the resources to do it.
Comment 17 Zibi Braniecki [:gandalf][:zibi] 2004-12-04 19:18:01 PST
oh, i just wrote my comment because of Comment 3.
Comment 18 A S Alam 2004-12-05 22:49:39 PST
(In reply to comment #15)
> Amanpreet:
> 1)
http://lxr.mozilla.org/aviarybranch/source/toolkit/components/help/locale/en-US/
> 2) Since Langpack is an extension, you have to generate unique ID for Your
> localization. On any unixlike machine You have "uuidgen" app which do this. I
> don't know how does it looks on windows, but google will know probably
DONE
> 3) In google
> http://www.kostis.net/charsets/
> http://www.dataparksearch.org/dpsearch-international.en.html
> http://www.columbia.edu/kermit/charsets.html
I check all, there is no specfication for Punjabi.
meanwhile, I do translation with UTF-8 encoding
Windows Also support for UTF-8 encoding.
Comment 19 A S Alam 2004-12-05 22:51:59 PST
Created attachment 167991 [details]
mozilla/browser/locales/pa-IN/defines.inc files

Update file with "uuidgen"
Comment 20 Zibi Braniecki [:gandalf][:zibi] 2004-12-06 14:03:50 PST
(In reply to comment #18)
> meanwhile, I do translation with UTF-8 encoding
> Windows Also support for UTF-8 encoding.

Benjamin? Is it truth? I'm almost 100% sure it's not...
Comment 21 Benjamin Smedberg [:bsmedberg] 2004-12-06 14:08:21 PST
Gandalf, I don't know of a legacy windows charset for Punjabi. We may not be
able to release a windows installer. Don't hold up the review on this point, we
can worry about it after the files have landed.
Comment 22 Sukh 2004-12-15 09:30:49 PST
There is no legacy character set for Punjabi on Windows.  I think there is on
the Mac (MacGurmukhi) which is based on ISCII.  Punjabi support on older
versions of Windows is the same as all Indian languages: non-existant without
proprietory font encodings.

Punjabi complex text rendering will only work on Windows XP and above or on
Windows 2000 if Uniscribe has been manually update.  Not sure how this stands
with MacOS or Linux...
Comment 23 Zibi Braniecki [:gandalf][:zibi] 2005-02-08 10:25:43 PST
checked in basing on attachment 167825 [details] with uuidgen and creator from attachment
167991 [details]
Comment 24 Axel Hecht 2005-02-09 01:03:35 PST
bustage fixes:

--- installer.inc       8 Feb 2005 18:17:54 -0000       1.1.2.1
+++ installer.inc       9 Feb 2005 08:42:26 -0000
@@ -9,7 +9,7 @@
 -#define SETUP_MESSAGE3%s $Version$ &#2600; &#2567;&#2616;&#2591;&#2622;&#2610; &#2581;&#2608;&#2600; &#2610;&#2568; &#2565;&#2583; &#2600; &#2598;&#2604;&#2622;&#2569;&#2404;
+#define SETUP_MESSAGE3 %s $Version$ &#2600; &#2567;&#2616;&#2591;&#2622;&#2610; &#2581;&#2608;&#2600; &#2610;&#2568; &#2565;&#2583; &#2600; &#2598;&#2604;&#2622;&#2569;&#2404;

... and then I replaced the installer with the en-US version. We don't have a 
native charset, so that is the best we can do. We need to release-note that
or something. I'll attach a patch of the stuff I backed out.
Comment 25 Axel Hecht 2005-02-09 06:38:17 PST
so, I changed 

Index: accept2locale.properties
===================================================================
RCS file:
/l10n/mozilla/toolkit/locales/pa-IN/chrome/global/Attic/accept2locale.properties,v
retrieving revision 1.1.2.1
diff -u -r1.1.2.1 accept2locale.properties
--- accept2locale.properties    8 Feb 2005 18:17:54 -0000       1.1.2.1
+++ accept2locale.properties    9 Feb 2005 14:33:58 -0000
@@ -25,6 +25,5 @@
 it = it-IT
 ja = ja-JP
 ko = ko-KR
-pa = pa-IN
 pt = pt-PT
 sv = sv-SE

too, to get the box green. 

http://lxr.mozilla.org/mozilla/search?string=getLocaleFromAcceptLang says that 
that stuff isn't really used anyway. Amanpreet, protest away if it does cause
trouble.
Comment 26 Axel Hecht 2005-02-09 06:41:01 PST
Created attachment 173848 [details] [diff] [review]
revert this patch to get the pa-IN installer files (which don't work due to charset)
Comment 27 A S Alam 2005-02-26 05:12:30 PST
>too, to get the box green. 

>http://lxr.mozilla.org/mozilla/search?string=getLocaleFromAcceptLang says that 
>that stuff isn't really used anyway. Amanpreet, protest away if it does cause
>trouble.
>

I am not able to understand this, latest Branch is not work for pa-IN locale for
Linux Machine. Can u pls give more information about it.
Comment 28 A S Alam 2005-03-03 17:52:01 PST
Created attachment 176214 [details]
/l10n-aviarybranch/ toolkit/ locales/ pa-IN/ chrome/ mozapps/ update/update.properties

file update for
app.update.url=https://update.mozilla.org/update/firefox/en-US.rdf 
as
app.update.url=https://update.mozilla.org/update/firefox/pa-IN.rdf
Comment 29 A S Alam 2005-03-20 23:47:27 PST
Created attachment 178097 [details]
update file for error chrome/pa-IN/locale/browser/browser.dtd

Error is removed and now it works well

chrome/pa-IN/locale/browser/browser.dtd
Comment 30 A S Alam 2005-03-23 18:12:34 PST
(In reply to comment #20)
> (In reply to comment #18)
> > meanwhile, I do translation with UTF-8 encoding
> > Windows Also support for UTF-8 encoding.
> 
> Benjamin? Is it truth? I'm almost 100% sure it's not...

for encoding, this may help
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/intl/nls_238z.asp
"0x0446 	Windows XP: Punjabi. This is Unicode only."

Comment 31 A S Alam 2005-04-20 19:23:19 PDT
Can someone please comment for this bug, as 1.0.1, 1.0.2 was missed for pa_IN
and now ready for missing 1.1a also.

thanks
Comment 32 David Baron :dbaron: ⌚️UTC-10 2005-04-20 23:11:42 PDT
If you want pa-IN Firefox 1.0.3 to ship, and if the current code on the aviary
branch is correct according to
http://www.mozilla.org/foundation/trademarks/l10n-policy.html and doesn't need
any other changes, certify the build according to the instructions in bug
288784, and then someone at the Foundation will check that you're following the
l10n-policy.html rules (since this localization hasn't shipped before), and it
should be able to ship.
Comment 33 Benjamin Smedberg [:bsmedberg] 2005-04-22 09:19:54 PDT
Amanpreet, the Firefox 1.0.x releases have been "missed" because you have not
asked for approval for this builds as noted in the netscape.public.mozilla.l10n
newsgroup, or attached whatever patches need to be committed to make them ready
for approval. Please indicate what further needs to be done for the branch. It
is clear that we cannot make a win32 installer, because there is no win32 native
encoding that will display punjabi. Since this is the case, we may release
everything except the win32 installer build.

I am marking a voucher for CVS access so that you can commit the pa-IN files on
the CVS trunk. Marcia and/or justdave will create your account and comment here
when your account is active.
Comment 34 Marcia Knous [:marcia - use ni] 2005-04-26 16:45:06 PDT
reassigning to dave, please create this account.
Comment 35 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-04-28 08:24:57 PDT
Comment on attachment 162275 [details]
ssh key

This is not text/plain! Looks like garbage.  Since the stored filename has a
.zip extension I'm going to take a guess that it's application/zip ;)
Comment 36 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-04-28 08:33:14 PDT
account created, key placed.

Your CVSROOT should be amanpreetalam%yahoo.com@cvs.mozilla.org:/l10n

If you have any trouble accessing your account, let me know.

Note You need to log in before you can comment on or make changes to this bug.