Closed Bug 264665 Opened 17 years ago Closed 17 years ago

recipients name not properly shown when national characters and "," are used

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: tobias-mailings, Assigned: mscott)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Thunderbird version 0.8 (20040913); Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

when there are national characters and commas included in a recipients or sender
address name, the display end up in a weird format.

Instead of "Müller, Mat., ABC" it shows Müller, Mat., ABC.

When replying to such email, there is not one recipient "Müller, Mat., ABC" but
three, one is Müller, second ist Mat. and thirs is ABC.

For better explenation, please see attached screen shots.

That is, I have only noticed this bug with some national characters.....

Reproducible: Always
Steps to Reproduce:
1. have some sending you an email with the display name including comma and
national character such as ö ä ü ß
2. after arrival, check the mail address in the mail viewer
3. reply to that mail and check the recipients address

Actual Results:  
Sender name gets broken into multiple parts

Expected Results:  
it should be just one part

I haven't noticed this in Thunderbird .7
Attached image broken recipient name
well, the national characters (ö ä ü ß) are not properly shown above....

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.