Browser hangs on exit, with blank window frame on desktop... eventually crashes

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Paul Lazaga, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a4) Gecko/20040930
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a4) Gecko/20040930

On browser exit there is a hang that eventually times out.  During the hang the
desktop is not functional.  I notice that when things are working that closing
the browser briefly brings up an empty window frame then closes.  This is more
pronounce when closing the mail portion client.

The following error in popuplog.os2 seems to be related.

10-16-2004  14:25:50  SYS3170  PID 0063  TID 0001  Slot 00b9
D:\BIN\MOZILLA.ORG\MOZILLA\MOZILLA.EXE
c0010001
1c03c4a1
EAX=3a4f40ce  EBX=00000001  ECX=6f6e6566  EDX=392cc0c8
ESI=00000000  EDI=8000150b  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1e99237a  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:0012ff48  SSACC=f0f3  SSLIM=ffffffff
EBP=0000f265  FLG=00012202

DOSCALL1.DLL 0003:0000c4a1

Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.

Updated

14 years ago
Severity: normal → critical
Keywords: crash

Comment 1

14 years ago
"Reproducible: Sometimes"... What did you do in cases where the hang occurs?
Visited certain URLs? Visited pages that triggered any plugins? Have you tried a
fresh profile to see if it still happens then?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> "Reproducible: Sometimes"... What did you do in cases where the hang occurs?
> Visited certain URLs? Visited pages that triggered any plugins? Have you tried a
> fresh profile to see if it still happens then?

I've been trying to figure out a pattern for some time.  The closest thing to
consistent has been after being to the site http://www.theregister.com/ although
I haven't been able to definitely reproduce the behaviour there either and am
not sure that it is the cause as the problem doesn't occur until exiting
somewhere later.  I haven't tried a new profile.  I was kind of hoping someone
else noticed this to give me little more direction in my search of reproducabiltity.
I see something similar to this but as I haven't come close to a recreate I
hadn't opened a bug.  It does seem more pronounced when using mail-news.  
The difference is that my desktop is not disturbed, I can keep on working, I can
even use other browser windows that were open but that blank window stays there
until I close every instance of Mozilla.  
It doesn't happen that often, just often enough to be noticeable.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> I see something similar to this but as I haven't come close to a recreate I
> hadn't opened a bug.  It does seem more pronounced when using mail-news.  
> The difference is that my desktop is not disturbed, I can keep on working, I can
> even use other browser windows that were open but that blank window stays there
> until I close every instance of Mozilla.  
> It doesn't happen that often, just often enough to be noticeable.

I do tend to have the email client open... it sounds like you are seeing the
same thing except I have the desktop lock with the process sometimes.

Comment 5

14 years ago
Ah, I can say that I have experienced something similar to what Andy describes.
But I get not crashes and can also continue to work in other opened windows.
That is with a nightly I built myself a week ago (ID below) and that does not
have a mail client, so it cannot be caused by that. The question remains, do we
talk about the same bug?
Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8a5) Gecko/20041011

Comment 6

14 years ago
Does anyone who sees this run the Sysbar/2 Task Switcher? Here that nice program
sometimes causes strange things (non-repainting Desktop, windows that don't want
to close, etc.) until I close or kill it?
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> Does anyone who sees this run the Sysbar/2 Task Switcher? Here that nice program
> sometimes causes strange things (non-repainting Desktop, windows that don't want
> to close, etc.) until I close or kill it?

I don't have Sysbar/2 here.  It is either a plugin, possibly java hang or a
particular page construction?  I'm still trying to see a pattern.
Product: Browser → Seamonkey
Still not sure if the problem I see is the same as the original issue but I
suspect a relationship between them.  I am not using sysbar, I have the
following enhancments:
xWP, Styler/2, estyler, dragtext, wpswizard, and lswitcher (as xcenter plugin).
This is on eCS 1.2 with Snap video, amouse 2.6.  
Andy

Comment 9

13 years ago
I haven't seen this in quite a while, well at least not the version of the bug I
mentioned in comment 5. Can others still reproduce?
I haven't seen it in some time either.

Comment 11

13 years ago
OK, I mark it WFM for now. If someone sees it again, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.