mail displaying is broken (last 1-4 symbols are cut from almost every line) for cyrillic text

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Seva Gluschenko, Unassigned)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.3) Gecko/20041008
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.3) Gecko/20041008

It looks like some Xft interacting bug. The mail window displays cyrillic text
without last symbols on every line longer than about 75 symbols. If the mail
text is long enough to fit into window, scrolling forward and then back restores
the text completely. Text remains broken until it's scrolled out and returned
back, so the end-of-text which didn't scrolled out remains broken in every mail.

Reproducible: Always
Steps to Reproduce:
1. Build with GTK2, XFT
2. Use Cyrillic KOI8-R encoding as a default, though I doubt it affects 'cause
Latin-1 mails were displayed normally.
3. Try it on wide mails with Cyrillic encodings
Product: Browser → Seamonkey

Comment 1

14 years ago
Seva Gluschenko, please supply a sample message -- save it as a .EML file and 
attach it to this bug using the Create New Attachment link above.
(Reporter)

Comment 2

14 years ago
Created attachment 170807 [details]
testcase

I removed confidential information from the header. Strings are pretty short
(it's lyrics), but last symbols aren't displayed, anyway (not in every line,
though).

I noticed also, the text gets displayed normally when it's selected and remains
normal while mouse clicks are limited to message area. When clicking in folders
area or folder index area, text gets perverted back.
(Reporter)

Comment 3

14 years ago
Created attachment 170813 [details]
one more testcase

this text is more wide, so the behaviour is more obvious.

BTW, even clicking into message area may result the text to be perverted again,
but it remains displayed correctly 'til selected, and the focus is in the text
area. Selecting text and clicking into folders area (so that focus moves into
that area) makes selection perverted, too.

Comment 4

14 years ago
Created attachment 170952 [details]
screenshot 

Disclaimer: I studied Russian for a year (25 years ago... :)  -- I can't
actually read the language, but I have a sense of what looks right and what
doesn't.  Both of those messages appear to display correctly; the attachment is
a screenshot of the first, on a Windows 2000 system, TB 1.0.
(Reporter)

Comment 5

14 years ago
Uhm... Sir, look at the very first sentence of my bug report again, pls.

"It looks like some Xft interacting bug". I'm pretty sure libXft has no place in
any WinXX.

Updated

13 years ago
Assignee: sspitzer → mail
(Reporter)

Comment 6

13 years ago
seems to be fixed in 1.7.6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.