XP SP2 run http://whatever starts TWO instances of the browser, plus no way to configure search engine as a limited user (and NO ERROR MESSAGE)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: priscilla junior, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

windows XP SP2 (perhaps caused by SP2?)
running as limited user, add search engine = does not appear in list, and NO
ERROR MESSAGE (I mean, if there was one, would be easier to troubleshoot)
should document where the profile is stored, which format etc to be able to
investigate. do not forget win XP home edition = hidden ntfs permissions, hard
to troubleshoot! :-(


starting from run box http://any url -> always starts TWO instances instead of
one! association registered at two places?


Reproducible: Always
Steps to Reproduce:
1. start http:// in run box as a limited user in XP home edition SP2
2. two instances are started instead of one

1. add wikipedia to search engines (as limited user)
2. no wikipedia in likst, remains the same

Actual Results:  
see above please

Expected Results:  
start only one instance of the navigator
add engine to list 
(used to work on other computer with xp he sp1)

Comment 1

14 years ago
this is Product Firefox, not Browser, please change it
Product: Browser → Seamonkey
Assignee: general → firefox
Component: General → General
Product: Mozilla Application Suite → Firefox
QA Contact: general → general

Comment 2

13 years ago
You're referring to two separate bugs here:

01. Limited user entering a URL at Start -> Run opens two instances of Firefox.
WFM, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050712
Firefox/1.0+. This issue may have been fixed since the original bug was filed.

02. Adding search engines without the necessary permissions causes the search
engine to be silently discarded. This is a known issue related to bugs 123315
and 124334. Did you search for duplicates before filing a bug report?

Comment 3

13 years ago
First issue is WFM, second is now fixed.  So both WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.