Extension manager should retrieve icon and description from install.rdf

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: edwin, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

When publishing extensions with JavaScript as described here
http://www.mozilla.org/projects/firefox/extensions/web-api.html, a friendly name
and a nice icon appears.

This does not work on update.mozilla.org/extensions.

I suggest the installer uses the friendly name and icon as is described in the
install.rdf.

Advantages:
1) installing an extension is friendlier, even on update.mozilla.org
2) extension authors don't have to make their webpages more complicated than
neccesary.

(I guess the whole point of putting all this information in the install.rdf file
is to provide all this. Why isn't it used [install.rdf is parsed anyway]?).






Reproducible: Always
Steps to Reproduce:
*** Bug 264759 has been marked as a duplicate of this bug. ***
Using it in the Software Installation dialog would involve fetching the XPI
before putting up the dialog, which would be a complete pain with big XPIs and
dialup, for very little benefit when there's an existing workaround. Sounds like
a near-certain WONTFIX.
Severity: normal → enhancement
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

14 years ago
yep, I agree it probably will be wontfixed, but you may want to file a bug
against u.m.o (if there isn't one already).

Updated

14 years ago
Depends on: 258991

Comment 4

14 years ago
update.mozilla.org now uses InstallTrigger - see bug 251050. Having custom icons
was suggested there, too, but that would require authors to upload a single
image file, or the software finding and extracting the icon from the XPI, then
putting the icons somewhere on the web server. Feel free to suggest such a thing
for u.m.o, but it does not sound worth the effort.

As Phil wrote in comment 2, fetching the XPI for the dialog is simply overkill,
and is a WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.