Hardcoded strings in Necko (nsSocketTransport, etc.)

VERIFIED FIXED in M17

Status

()

defect
P2
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: rchen, Assigned: ruslan)

Tracking

({l12y})

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+]2d)

"Transferring" hardcoded in
/netwerk/base/src/nsSocketTransport.cpp, line 1933 -- static nsAutoString
frommesg("Transferring data from ");

Please remove it to DTD
Blocks: 24298
Keywords: beta1
There's one of these in nsFileTransport too: "Wrote ..." (and looking at it, it 
doesn't even work right in non-debug mode). There are probably others in necko 
-- and we need to come up with error messages that can be propagated up through 
OnStopRequest. 

Changing summary from: Hardcoded strings in nsSocketTransport.cpp
to: Necko needs internationalization (nsSocketTransport, etc.)

Assigning to Jud. Marking M15 (post beta). I think these don't show up that 
often.
Assignee: warren → valeski
Summary: Hardcoded strings in nsSocketTransport.cpp → Necko needs internationalization (nsSocketTransport, etc.)
Target Milestone: M15
Add bobj, msanz, ftang, tao. 

Necko is NOT internationalized.
Changed summary back to referring to "hardcoded strings".
Internationalization is a big area, this is more descriptive of this
particular bug.

For more on Seamonkey string resources, see
     http://www.mozilla.org/projects/intl/string-resources.html
Summary: Necko needs internationalization (nsSocketTransport, etc.) → Hardcoded strings in Necko (nsSocketTransport, etc.)
Not aboslutely essential for Beta. Marking PDT-.
Keywords: beta1
Whiteboard: [PDT-]
Warren, can you provide us the list of error messages? 

We are localizing Japanese Beta1. If you think these error messages are not 
going to show up to the users, we can wait until M15. Otherwise we prefer to 
have them moved to DTD or properties before beta1. 
Add beta2 keyword and M16 target
Keywords: beta2
Priority: P3 → P2
Target Milestone: M15 → M16
Blocks: 12394
*** Bug 33795 has been marked as a duplicate of this bug. ***
Moving to M17 (also beta2).
Target Milestone: M16 → M17
Whiteboard: [PDT-]
Status: NEW → ASSIGNED
Whiteboard: 2d
Keywords: nsbeta2
Moving to gagan per valeski- Putting on [nsbeta2+] radar for beta2 fix. 
Assignee: valeski → gagan
Status: ASSIGNED → NEW
Whiteboard: 2d → [nsbeta2+]2d
ruslan we should coordinate with rchen to also make sure the redirect_loop is 
internationalized as well as any strings that necko handles. 
Assignee: gagan → ruslan
Yeah. I'll try to clean this up.
Status: NEW → ASSIGNED
Fixed
Oops. Changing status to fixed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
verif.
NT 2000053008
Status: RESOLVED → VERIFIED
Keywords: l12y
You need to log in before you can comment on or make changes to this bug.