system crash leaves profile inaccessible

VERIFIED DUPLICATE of bug 151188

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 151188
13 years ago
13 years ago

People

(Reporter: Geoffrey Leach, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3

I'm using the default profile.
Following a system crash (power failure) Firefox finds the default profile in
use and insists that I create another.  Removing the "lock" symlink did not
help, nor did rebooting.

I'd like to get my original profile back, as it has all of the loaded extensions.

Reloading ~/.mozilla from backup has the same problem, as the backup was created
with FF in use.


Suggestion for an extension: allow the profile manager to override the lock.

Reproducible: Always
Steps to Reproduce:
1.crash the system with ff in use
2.restart system 
3.restart ff

Actual Results:  
ff starts with profile manager, reports default profil in use.

Expected Results:  
give me the option to override the lock.

Comment 1

13 years ago
May be a dup of Bug 151188
(Reporter)

Comment 2

13 years ago
It is indeed a dup of 151188

*** This bug has been marked as a duplicate of 151188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.