Find as you type auto-launching even when disabled

RESOLVED DUPLICATE of bug 254592

Status

()

--
major
RESOLVED DUPLICATE of bug 254592
15 years ago
11 years ago

People

(Reporter: trav, Assigned: bugzilla)

Tracking

1.7 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

I have noticed a problem when typing in textarea boxes, at least on a particular
forum http://forums.macrumors.com

When I am typing a reply to a thread, if a word I've typed has the single quote
in it (such as with the word "I've"), hitting that single quote character seems
to result in "type ahead find" launching on its own - even though I don't have
"Use Find as you Type" enabled.

This seems to be a new problem in Firefox PR 10/10.1

Don't know if this is specific to OS X build or not.

UPDATE: As I was entering this bug, I saw this happen on this enter_bug.cgi
page. It started after I hit the "/" character two paragraphs above - now if I
hit ' or / find as you type launches. So I can only type those characters by
hitting them, then waiting until find as you type times out (which fortunately
I've set for a short interval).


Reproducible: Sometimes
Steps to Reproduce:
1. Start typing in a textarea box
2. Type something that uses a single quote "'" or a slash "/"
3. Notice that find as you type launches itself

Actual Results:  
The things I was trying to type into the textarea box were instead being used as
find as you type input.

Expected Results:  
My typing in the textarea box should have continued unhindered.
(Reporter)

Comment 1

15 years ago
This seems to be virtually identical to some of the "me too" posts on bug
258285, although it is somewhat different than the actual bug report in that
case. Since some of those posters were on different architectures, I'm removing
the OS and hardware specifics (assuming of course that I'm allowed to do that!).

Also I mistyped the version - it should be Firefox 1.0PR
OS: MacOS X → All
Hardware: Macintosh → All
Version: unspecified → 1.0 Branch

*** This bug has been marked as a duplicate of 254592 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.