If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cncelling master password prompt causes repeated prompts

RESOLVED DUPLICATE of bug 210433

Status

SeaMonkey
Passwords & Permissions
RESOLVED DUPLICATE of bug 210433
13 years ago
13 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Assigned: dveditz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927

I have stored a login name and password for the page http://www.mail.com/ 
and I use encryption to protect my passwords.  So, every time I go to that
URL, I get a master password prompt.  Sometimes I enter the master password
and press OK.  But at other times, I'd rather just type in the acount name
for that page directly, and not use the wallet/password manager to fill it
in for me.  On those occasions, when prompted for my master password, I bonk
the Cancel button.  I expect the master password prompt to go away and not 
come back immediately.  But what happens is that the prompt comes right 
back, until I have cancelled it a few times.  

Then if I type in a password, and press enter, it prompts me for the master
password again, also several times.  This is such a waste of time.  
Very annoying.

Reproducible: Always
Steps to Reproduce:
0. First, have stored a password for www.mail.com, then
1. Go to http://www.mail.com/
2. when prompted for the master password, press cancel button.
3. 

Actual Results:  
The master password prompt comes right back again.

Expected Results:  
The master password prompt should go away and stay away for that page.

I am using mozilla (seamonkey) 1.8a4.
(Reporter)

Comment 1

13 years ago
marking as a trunk bug, since this is seamonkey 1.8a4.  Please correct if wrong.
Version: 1.4 Branch → Trunk

Comment 2

13 years ago
Related to/duplicate of bug 210433 and/or bug 134593?
(Reporter)

Comment 3

13 years ago
Zug, good catch.  Thanks.
Based on https://bugzilla.mozilla.org/show_bug.cgi?id=210433#c5 which says
"On pages with X fields, the dialog is reasked X times, after pressing Cancel!"
I am marking this bug as a dup of that one.

*** This bug has been marked as a duplicate of 210433 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.