philips.com - Bad display.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Jean-Michel Pommez, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

IE6 display is correct

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Possibly a dup of Bug 262679

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041110
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

The rendering in the menu to the left is a dupe of
Bug 262679 philips.ch - improper use of CSS height causes text overlap
As bug 262679 seems to be fixed, there is only a screenshot to be seen:
https://bugzilla.mozilla.org/attachment.cgi?id=160913&action=view


JS Console is showing a lot of CSS-Errors, a lot of JS Warnings, and three JS
errors:

Error: gE("p-stockquotes") has no properties
Source File: http://www.semiconductors.philips.com/crsc/scripts/lib_global.js
Line: 322

seen in Mozilla only:

Error: gE(dd) has no properties
Source File: http://www.semiconductors.philips.com/crsc/scripts/lib_global.js
Line: 1319

Error: [Exception... "'Permission denied to get property XULElement.accessKey'
when calling method: [nsIDOMXULLabelElement::accessKey]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
http://www.semiconductors.philips.com/crsc/scripts/lib_global.js :: getItemLevel
:: line 2264"  data: no]
Source File: http://www.semiconductors.philips.com/crsc/scripts/lib_global.js
Line: 2264

While loading the page in Mozilla, I also got a warning that a script on this
site may hang Mozilla, I acknowledged to continue running the script.
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: firefox.general → general
Summary: Bad display. → philips.com - Bad display.
Version: unspecified → Trunk
Product: Browser → Seamonkey

Comment 3

14 years ago
I can't reproduce this issue. Please confirm if you still have this problem then
we can take a look at it. Otherwise please close this issue

Comment 4

14 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050207
Firefox/1.0+

(In reply to comment #3)
> I can't reproduce this issue. Please confirm if you still have this problem then
> we can take a look at it. Otherwise please close this issue

Thank you for looking at this.

The current behaviour is very similar to comment 2 , I get the script warning
(I cancelled) and numerous JS and CSS errors.

I didn't see the erroneous render, perhaps because I cancelled.

Comment 5

14 years ago
(In reply to comment #4)
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b) Gecko/20050207
> Firefox/1.0+
> The current behaviour is very similar to comment 2 , I get the script warning
> (I cancelled) and numerous JS and CSS errors.
> 
> I didn't see the erroneous render, perhaps because I cancelled.

The current state of this report might well be the same as 
Bug 262679 "philips.ch - improper use of CSS height causes text overlap"
in which case it is at least in the running for being RESOLVED FIXed.

Thank you for attending to this.

Comment 6

14 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b) Gecko/20050209

(In reply to comment #3)
> I can't reproduce this issue. Please confirm if you still have this problem then
> we can take a look at it. Otherwise please close this issue

The bug was about bad display, overlapping text like seen in Bug 262679.
This is gone, page renders fine, so I resolve as WORKSFORME

There are still some CSS errors seen in JS console of Mozilla 1.8b
It´s mostly about cursor, margin or background MS or W3C-style, I didn´t miss
stuff when looking at the content of the page. 

There is a typo, a 't' too much : 'postition' ==> 'position'

Error: Unknown property 'postition'.  Declaration dropped.
Source File: http://www.semiconductors.philips.com/styles/semi_styles.css
Line: 112

from the source:
/* extra module type news*/
.div-container{
	postition:absolute;
}

or see validator at w3
http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fwww.semiconductors.philips.com%2Fstyles%2Fsemi_styles.css
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.