Closed Bug 264876 Opened 15 years ago Closed 15 years ago

Find Toolbar appears when pressing ' or / in HTML textarea

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 258285

People

(Reporter: goa103, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

Since I installed Firefox 1.0PR, I find the Find Toolbar very useful. But
sometimes I get bothered because it appeared without asking, while I was writing
something into a textarea. After a few try and reading the Help, I found out
that the ' key was a keyboard shortcut named « Find As You Type Link ». But this
feature shouldn't be enabled in a HTML textarea. Sometimes pressing ' doesn't
popup the Find Toolbar, but sometimes it does, like if the textarea hadn't the
focus. But it does have the focus as I'm writing some text into it.

To sum things up, I don't know how it happens, but sometimes the HTML textarea
we write to hasn't got the focus, and it should have it to avoid the Find
Toolbar to popup when pressing the « Find As You Type Link » keyboard shortcut «
' ».

Some end-users feedback about Firefox and this annoying bug :
http://forums.mozillazine.org/viewtopic.php?p=881166

Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Pressing the « Find As You Type Link » keyboard shortcut « ' » from a HTML
textarea pops up the Find Toolbar.

Expected Results:  
Pressing ' shouldn't pop up the Find Toolbar, it should write ' to the HTML
textarea.

*** This bug has been marked as a duplicate of 258285 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
*** Bug 265131 has been marked as a duplicate of this bug. ***
*** Bug 265418 has been marked as a duplicate of this bug. ***
Confirmed based on dups.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Find Toolbar appears when pressing ' from a HTML textarea → Find Toolbar appears when pressing ' or / in HTML textarea
I just encounterd this myself while replying to a post on Slashdot.  As I was
typing, every time I used a single-quote mark ('), Firefox openned the fast find
toolbar at the bottom and moved my focus to that field.  The quote was left
intact in the textarea, however, so hitting ESC to close the find toolbar worked
for me.

That said, what I find interesting is that it didn't happen in this textarea
which is in an IFRAME from the main Bugzilla search page.

Not sure if that helps.
I thought you might also be interested to know that bug 220900 also deals with
focus breaks. I mention it in bug 220900, comment 73.
*** Bug 278321 has been marked as a duplicate of this bug. ***
Dupe of bug 250411?
This bug is affecting me as well and I can reproduce it somewhat readily by
simply trying to compose and email at yahoo.com OR JUST NOTICED IN THIS TEXTBOX
ITSELF JUST NOW (THRICE, IN FACT).

I'm using Firefox 1.0 on Mepis, so this isn't a windows specific problem. 

At first it was reacting to both / and ', but after changing
accessibility.typeaheadfind.startlinksonly to false, it seems to now only be
when I type apostrophes.

Precise behavior: When I'm (!stolen focus!) typing slowly (<= 30wpm) about 25%
of the time when I type an apostrophe it launches the find bar, which steals
focus and causes me all sorts of difficulties.  It did it on the ' in I'm (ok)
at the beginning of this paragraph, and I'm (ok) typing at maybe 5 to 10 wpm
right now.

When I'm (!stolen focus!) typing faster, which for me at my peak is about 35-45
wpm, it seems to happen more often, maybe 50% to 75%.   It MIGHT be that
sustained 30+ wpm typing causes it to trigger on every apostrophe, whereas just
a quick word or two that has a an apostrophe in it doesn't (ok) usually trigger
it.  A lot of unfamiliar words in the above, so my typing speed had dropped back
down to maybe 15 - 20 wpm.

It's a show stopper that makes firefox almost unuseable.  I have lost and had to
recreate about a half dozen emails now.  When "find" steals focus, it shifts
focus out of the text box, so after I pause for long enough for the bar to go
away, I then press backspace to fix the errors it introduced into my text, which
promptly sends me back a page, losing all my already-written text.
(In reply to comment #9)

1. go on website with online forms
2. start filling the form
3. hit ' or / in the form
4. enjoy the search bar appearing at the bottom

( hmmm ... strange: it happens with the form of the bug filler, but not with
this message box ... ) 

GRAAAAAAAAAAA it happened 1mn ago when filling an other bug, and not any more.
Murphy ! COME BACK !

*** Bug 283393 has been marked as a duplicate of this bug. ***
> ( hmmm ... strange: it happens with the form of the bug filler, but not with
> this message box ... ) 
> 
> GRAAAAAAAAAAA it happened 1mn ago when filling an other bug, and not any more.
> Murphy ! COME BACK !


I find that switching tabs to another textarea often resolves it.

(FC2, Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1)
This sounds like a focus issue.  Ccing aaronlev and bryner.
This sounds a lot like bug 258285
This happens to me daily when posting to phpBB and vBulletin message boards.
Sometimes the Find Toolbar gets stuck and will NOT go away without shutting down FF.
*** Bug 297978 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4

I have this bug too.  When it happens, you can't use the arrow keys within the
text box even if you've closed the finder toolbar.
Flags: blocking-aviary1.1?
Without a testcase of something that consistently breaks, this is basically
focus screwing up and probably a dupe as originally marked.

If someone can come up with clear steps, please nominate for b4.
Flags: blocking-aviary1.1? → blocking-aviary1.1-

*** This bug has been marked as a duplicate of 258285 ***
Status: NEW → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
I get this bug now and again with Windows XP Home, Firefox 1.5.0.7 in an gmail message body field, only with the apostrophe (') key.  

I can only get the find bar to appear on purpose in Gmail by hitting TAB to select the SEND button and then hitting apostrophe (').  It's not the same as the bug state, however, because when I click back on the text field it does not occur again.  
Product: Firefox → Toolkit
Sorry, brand new here, Can confirm that bug with hitting (') or (/) brings up the "quick find (link only)" search box.

It continues to happen and I cannot find the reason why or how to stop it.
You need to log in before you can comment on or make changes to this bug.